Incorrect robot movement after battery replacement

  • Hello, the voltage on the batteries was lost and they were replaced, after that mastering and calibration was done, the TCP was set up, but after all this the robot moves uncorrectly, that is, I choose the WORLD coordinate system (or any other except JOINT) and when I start moving the robot along the X coordinate, the robot instead of straight-line movement, it moves diagonally, along the Y coordinate instead of the linear one, moves in an arc, along other coordinates +- the same thing, maybe who knows what the problem may be. Maybe I did incorrect mastering or setup of the TCP. Robot Model: FANUC ARC MATE 120IBE

  • Place your Ad here!
  • System-Variables-$MASTER+ENB


    Try this and Remaster and let me know what happens?!



    • Nothing has changed, the robot also moves incorrectly in any coordinate system except JOINT, I will try to explain to you (it would be easier to attach a photo, but I don't really understand how to do it), after remastering and calibration, I choose a coordinate system, for example WORLD, and move the robot along the Y coordinate, the robot from point A to point B moved exactly along the line, before replacing the batteries, now this movement is in an arc (as if I put a JOINT and moving the fourth axis, something like this), after I set up the TCP, nothing changes, the robot moves the same way, maybe I'm doing something wrong or what-I miss it, but I have not met such a problem before, I tried restore image (I did everything according to the manual) nothing has changed, the robot also moves incorrectly and all this after replacing the batteries.
  • How did you do the Mastering ?

    At first I had SRVO-062 BZAL error, I did Menu->System->Master/cal and press F3 (RES_PCA) > F4 (yes) and rebooted the controller, then there was SRVO-075 Pulse Mismatch error, I moved the robot axes +/- 5 degrees, the error is gone (I do everything according to the manual). Then Menu -> System -> Variables> $MASTER_ENB and change it from 0 to 1, then > jog each joint of the robot until the reference marks used are align (most of the time they are the 0° marks of each joint), press MENU -> 0 (NEXT) -> SYSTEM -> Variables > $DMR_GRP and press the ‘Enter’ button twice, then you need to find the system variable $REF_COUNT and press ‘Enter' -> make sure that the values for each of the axes in this system variable match the values specified in the work passport (everything coincided). Then F1 (Type) -> Master/cal -> QUICK MASTER press Enter and F4(yes), then choose CALIBRATE - enter- F4(yes) wait for the procedure to complete F5(DONE), this is all that was in the manual, maybe I'm doing something wrong, I will be grateful for any help, thank you.
    P.S. sorry if it was written incorrectly somewhere, I use a translator, of course I double-check everything myself, but you never know, ty.

  • Also make sure that the $DMR_GRP[1].$REFPOS was set to 0° to all axes.


    But also, seeing as this is an older robot, one or more of the motors and/or pulsecoders might have been replaced, and thus the original master data is no longer valid.


    If nothing else works I would suggest getting it fixture mastered by a FANUC service engineer.

  • I have seen cases similar (not necessary identical) where:

    - Robot model/software is not correct and mechanical differences such as gear box direction is different.

    - System integrator initially did not master in usual manner, specifically with minor axis.


    When you move all joints individually, are you sure they are all moving in the correct directions as per axis keys pressed with respect to the physical direction the joints are responding to.

  • Using Quick Master Option was probably not the good choice.


    A good check is to jog to witness marks and verify the position reading on teach pendant


    Since you have jogged to witness mark (0 degres), i would use Zero Position Master in the menu.

    If it starts well the first time, you have not checked all !

  • Using Quick Master Option was probably not the good choice.


    A good check is to jog to witness marks and verify the position reading on teach pendant


    Since you have jogged to witness mark (0 degres), i would use Zero Position Master in the menu.

    Agreed, This is what I did the first time setting up a Fanuc robot and used the MASTER_ENB$ to set each axis at a time! Also now I would check and make sure it is 0 degrees!

  • I did it, now the robot is working correctly. If anyone is interested, the problem was as follows:

    1. I found out that the batteries were replaced when the robot's power was turned off, because of this, using Quick Master Option its really not the good choice (in this situation it will not work because he mastering data were lost from the robotcontrol unit).

    2. The second problem was in incorrect zero position points.

    When I correctly set the robot to the zero position points and made the Zero Position Master, after I calibrated and configured TCP, the robot worked correctly.

    Thank you all for your feedback.

  • Actually, a Quick mastering is exactly what should be done after the pulsecoders has lost their values (as in your case).
    However!

    In order for a QM to work, it's essential that the QM ref.pos has been set (normaly this is set to 0° on all axes) and that the ref_count values are saved. At least in the form of sysmast.sv-file (as part of an All Of Above backup) but preferrably also written down.

    Especially if the unit has had some mechanical alterations done (motor change for instance).


    The Zero Position Master is only as accurate as your eyes.

  • Watch out !

    Quick Master is exactly like a MasterPos master, except it use another réf.pos that is custom defined to be able mastering with eoat attached to robot by using specific reference on the EOAT and cell environment (fixture,etc…).


    It needs to be fully defined before using it.

    By default, réf.pos of Quick Master is 0 degree for all axis.

    If it starts well the first time, you have not checked all !

  • I know that the Zero Position Master is not as accurate as another type of mastering, as it is written in manual: “ ZP mastering cannot be performed as accurately as other types of mastering, because the combination is performed visually. Perform mastering at ZP only as an emergency measure.”


    and about Quick Master it is written: " ...Then you need to find the system variable $REF_COUNT and press ‘Enter'. Make sure that the values for each of the axes in this system variable match the values specified in the work passport. If they are missing, they must be entered/changed to passport (if the location of the passport is unknown, please contact the FANUC representative office)..."


    I searched again and asked the management, but I could not find the passport data, and due to the circumstances in my city, contact the FANUC representative office is not possible for me, so it was decided to do ZP mastering, something like that.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners