Get robot.ini file for offline compilation

  • What I'm trying to achieve is creating some sort of automated compilation of multiple KAREL source files with ktrans.exe. It works fine until I start compiling files where for example I wish to read system variables through $VARIABLE_NAME instead of using the GET_VAR routine. The compiler needs to know some information about the robot (and indeed, for successfull compilations it already warned that robot.ini could not be found).

    So my question is how to get this robot.ini file for a specific robot? I can run setrobot.exe and select the required cell from the neighbourhood and it doesn't throw any errors, however it doesn't output a robot.ini file as I had hoped for (or at least, not at the root or any places that made sense to me). Am I looking in the wrong places? Any pointers/background/solutions would be appreciated.

  • Place your Ad here!
  • Lemster68

    Approved the thread.
  • Run it in cmd prompt and pay attention to the current directory cmd prompt launches in.

    What do you mean by "it", the setrobot executable? When I run this (from the project's directory in cmd prompt) and select the robot from the nieghbourhood, it simply outputs "Setrobot V9.40-1, Copyright (C) 2004, FANUC Robotics America, Inc.", then when I run the ktrans command to build the program, I still can't find the robot.ini file. I feel like I'm lacking understanding of how it's supposed to work.

    Edited once, last by hoitzing ().

  • Yes, by it I mean setrobot. I open cmd prompt, look at the directory (usually it says "c:\users..." then type in setrobot and select the robot. The robot must be one created in Roboguide and have Roboguide closed. Then it creates the .ini file in the folder shown at the beginning of cmd prompt.

  • I think the fact it has to be created with Roboguide is where I went wrong. When I tried running it on a cell I made via an existing robot in the neighbourhood it didn't output anything. Now I tried adding a virtual robot to the neighbourhood that's from a roboguide backup, it works. Still not entirely sure if that's really the prerequisite I missed before, but at least I've got something working now. Thanks!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners