Roboguide installation problem in Windows 11

  • Hello everyone,

    I was trying to install fanuc roboguide (9.4 Rev V and rev H) in a new laptop with OS Windows 11, but the setup is not working properly, Has anyone had the same problem? Is this a compatibility trouble?

    Thank you in advance.


  • HawkME

    Approved the thread.
  • I've already tried running with and without administrator privileges, also run it in "compatibility mode" but the error still there.

  • Hello,

    I had the same problem. I found a way around by installing a previous revision of roboguide and then installing the current revision.

    Error messages still appear during installation, but roboguide works.

  • Why don't people EVER read the provided documentation when installing software anymore. :censored:

    Fanuc supplied DVD's ALWAYS have readme and release note files and I recommend reading these BEFORE clicking on any setup.exe.

    As HawkME mentioned, installing must be run as administrator or administrator login level.

    Installing it and THEN running it as administrator is not the same thing.

    Not to say this is your issue, but the error clearly points to 'permissions'.



    - System requirements and others

    Please refer readme.txt and doc/ROBOGUIDE_Remark_eng.txt

    - How to Install

    Use Windows Update before the installation.

    Login Administrator.

    Please confirm security settings for install ROBOGUIDE.

    Disable antivirus software and other softwares.

    Run setup.exe as administrator. (Right click menu [Run as administrator])

    Please install the latest FRVRC at least.

    Please login Administrator again after the PC rebooting.

    And please run ROBOGUIDE as administrator to confirm ROBOGUIDE works correctly.

    (If ROBOGUIDE does not work, please install it again.)

    Please consider to update graphic driver.

    If graphic driver is old, ROBOGUIDE might work correctly or ROBOGUIDE might be slow.

    ROBOGUIDE might not work correctly with graphic driver from non graphic chip vendor.

    (*) If antivirus software is enabled, installing this software might consume much time.

    (*) If installation stops, please try again.

    (*) If you encounter installation error, please disable antivirus software and try again.

    (*) If you encounter installation error, please try Windows Update before installation.

    (*) If you encounter installation error, you may need to enable compatible mode of the setup.exe.

    (*) If you encounter installation error of the download version, you may need to install from DVD that is burned the downloaded installer.

    If you encounter 'Exception Code (xxxx,xxxx) raised from ISRT_CreateObject' error,

    please install LicenseChecker\setup.exe first. Then run setup.exe.

    Enough disk free space is needed.

    You cannot install ROBOGUIDE if port 3002 is used. Please install ROBOGUIDE to PC

    which port 3002 is not used.

    [Adjust which additional application features you want to] Screen

    If you check the License Server and install it, LicenseServer will be installed.

    Also, if you install without checking, nothing happens for LicenseServer.

    Details about LicenseServer are described in "ServerLicenseSummary" in the doc folder.

    - Registration

    You can use ROBOGUIDE as trial version for 30 days.

    If you purchase ROBOGUIDE, you need registration.

    Please open license screen from ROBOGUIDE menu Tool/Register SimPRO.

    Please send Part number, software code 1 and software code2 to FANUC sales. You will

    get registration key REG1 and REG2, then input them in the license screen to register.


  • I have full administrator rights on my laptop, and running the setup as administrator did not solve the problem for me.

    Were not talking about your issues and we have no idea about your issues or errors do we?

    Their error relates directly to permissions.

    Therefore I provided the information Fanuc provides outlining installing it.

    I've never had ANY issues with installing Roboguide versions.

    Are you saying I'm incorrect about the information I provided by Fanuc then?

  • Are you saying I'm incorrect about the information I provided by Fanuc then?

    I'm saying that I had the exact same problem with the exact same error message during installation, and running the install as administrator was the first thing I did, and it didn't solved the problem for me.

    I'm just sharing my experience with this problem.

  • I also had the same experience as Keridor, on Win 10 fresh installed, updated to the actual patchlevel.

    Installing first an older version of Roboguide, then the newer version worked also for me. But don't remember the exact version numbers.

  • Hello,

    I always run the setups as administrator or administrator login level, the computer is new, and doesn't have any type of security (antivirus, corporative locks, etc), in the readme file of Rev V doesn't say anything about WIN 11, only in the Rev. X so I installed it but the message still there and roboguide didn't work. So I tryed to install a previous version (8.5) then unistall and then install the rev X version. Now roboguide opens, but I dont think that its working properly, cause it takes a much time to create a empty robot, and if I open a backup cell some warnings appear.

    Let me know if you find another solution. As additional information I intalled roboguide in Win11 22H2 Home edition.

    Thank you for your help.

  • I had the same problem last month.

    Logging in at administrator level and turning off firewall etc didn't help.

    Then uninstalled the current RobotGuide and installed an older version.
    This one worked, then installed the latest version over it.

  • I was trying to install fanuc roboguide (9.4 Rev V and rev H)

    Do these versions in the provided readme file have windows 11 as a supported OS?

    Ver9_RevZ that I downloaded from Fanuc directly went straight into my windows 11 setup and in the readme file widows 11 is there as a supported OS.

  • Hello,

    Ver 9.4 Rev H in the readme file doesn't mention if it is supported for Win 11, in the 9.4 rev X should be supported acording to the readme file, but maybe only for an earlier version of WIN11, because it didn't work for me and my current version of Windows 22H2.

    So after install and uninstall roboguide in their different versions, the message of the permisions still there but now roboguide is working well, I can work with it

    Maybe I should try with the 9.4 Rev Z, when I get it.

    Thank you so much for your help!

  • I am running ROBOGUIDE on a Windows 11 computer without any problems. Install revision T first and after that, you can install a newer revision. Simply confirm the upcoming error messages and continue the installation. It is important to install ROBOGUIDE as administrator.

Advertising from our partners