4400 and 140 cease to work, cabsta.c cabts.c servots.c

  • We have multiple ABB robots on site and one processing cell went unused for a month or two. I've come back to it and found that the 4400 and 140 in that cell aren't happy.

    The 4400 has an S4C+ controller and will boot, get past counting, but then shows errors:

    safevtts.c 620 Couldn't i

    runchn.c 1033 can't write

    runchn.c 1073 can't write

    runchn.c 1113 can't write

    cabsta.c 435 Count ini

    cabts.c 2430 Cansta init

    servots.c 1213 Not allowe

    servots.c 1213 Not allowe

    I can go to the program window but it won't load or create a program.

    I can make backups or restore known good backups but the problem persists.

    We've removed the PC, reseated the boards, cleaned dust and reassembled but the problem persists.

    The robot has worn batteries and needs calibration (rev counter update) during any power cut, but this is commonly performed without issue.

    You can go to the rev counter update screen and say update but it doesn't seem to make any difference to the errors.

    It's strange that both the 4400 and 140 have issues simaltaneously. Makes me think a power cut or something upset them. The 140 has slightly different issues but lets focus on the 4400 for now. Has anyone got any idea how to sort it?

    We've tried restart, i start and x start. Run out of ideas really.

    I did image the 64MB flash disk to a spare in 2014, then that spare failed in 2016 and I swapped back but that was all to do with counting on startup, not the current errors which I've never seen before. I have ordered a new spare and will attempt to put the image on the new flash disk when it arrives but I don't think this will resolve the issue.

    Please help. Is there anything we should try?

    Edited once, last by iano ().

  • Thanks for the advice so far.

    Lemster68, Apologies, I don't know which LEDs specifically that you're referring to.

    The back of the computer has:

    Status green

    HDD orange when active (but settles to off after boot)

    Power green

    On the right of the cabinet we have a DSQC 504 with:

    CAN1 NS (network status) green, and MS green

    CAN 2 NS is not illuminated, MS is green

    On the back of the cabinet there is DSQC 509 with:

    EN not illuminated

    MS green

    NS green

    ES1 Orange

    ES2 Orange

    GS1 Orange

    GS2 Orange

    AS1 not illuminated

    AS2 not illuminated

    There's also two IO boards DSQC 328, both with:

    MS solid green

    NS blinking green

    Skooter, I'm not sure which is the IO computer card but I pulled cards from an old controller and found:

    The large CPU board with the many wired connections was already borrowed from the spare computer in 2016 and installed in this robot that is now having issues.

    The small board (X2 Axis Computer?) can be swapped but behaves in exactly the same way.

    The larger board with the ethernet port cannot be swapped, won't get beyond counting on the pendant/stuck in boot when the spare is installed. The spare may not be good but I'm not sure this is the board you wanted swapping anyway.

    We did try reloading the software over a network connection and restoring backups yesterday but it didn't alter the behaviour :(

    After a successful boot, here is the list of errors:

    50242 Unsync due to CFG data

    50242 Unsync due to CFG data

    50242 Unsync due to CFG data

    50242 Unsync due to CFG data

    50242 Unsync due to CFG data

    50242 Unsync due to CFG data

    38031 Resolver signal error

    50057 Joint not synchronised

    50057 Joint not synchronised

    38031 Resolver signal error

    20031 Axis not calibrated

    10035 Axis not calibrated

    10211 Execution cancelled

    20311 Enable 1 open

    10014 System failure state

    10015 Manual mode selected

    20076 Not allowed command

    20076 Not allowed command

    20076 Not allowed command

    I'm not too concerned with the first errors as we probably just need to update rev counters, I think those errors correspond to that but I can't update the rev counters due to the system failure state.

    There's a couple of concerning messages in the errors, 38031 Resolver signal error shows:

    Too low resolver voltage detected on joint irb_6

    That isn't something I'm familiar with. Any ideas what to do?

    50242 Unsync due to CFG data shows:

    Mismatch between controller and cfg data for joint irb_6 (calibration offset or calibration position)


    Valid flags for calibration offset or commutation offset not true in cfg.

    I'm still not sure if all this is to do with some messed up config file or whether some hardware has actually failed.

    Any help would be much appreciated.

  • Looks like you just need to fix the resolver error.

    A6 resolver error could be the serial measurement unit, the resolver or the cables/connections in-between. Makes sure the 4-6 cable at the SMU is seated and the shielding secured, resolver connection is properly connected at the motor. DO NOT remove or adjust the resolver.

    Easiest is to try another SMU if you have one.

    If you have a spare motor, you can plug A6 motor resolver connector to the spare motor resolver connection then power up and see if it reads properly without error.

  • I tried a suspicious spare SMB yesterday and it didn't work but then, following your advice, pulled a known good working SMB from another robot and it resolved the error on the 4400! Massive relief, thanks for all the help. I've labelled the spare SMB as suspected faulty so I don't waste time on it again, should probably chuck it.

    Moving on to the 140 robot, it was showing IO errors and replacing the large IO board in the PC didn't fix it but ultimately, seeing that the DSQC 509 in this controller didn't have EN, MS or NS illuminated, I tried a spare from another robot and it fixed the issue!

    Everything working, very happy.

  • Good troubleshooting, I've had that happen to me too.

    DSQC509 age out after time and need their capacitors replaced, especially if the older ones were 85°C instead of 105°C.

    Show the controller more love by verifying all the fans and a fresh 2032 battery for the CPU card. Don't forget the filters.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now