kuka kr210 L150-2 k2000 variation in cartesian data while moving from 0 to +_90

  • kuka kr210 L150-2 k2000


    I am working with milling application with this robot.

    This is not position accurate robot. I checked for .pid file inside controller but wasn't able to find.


    having issues with cartesian values which robot is giving.

    A1 axis for 0,+90,-90 position gives different values for X,Y,Z.

    it gives variations while machining using track.

    but my concern is this changing of values.

    for Y axis when robot is in home position its value is changing over a period of time (2 weeks approx).

    it got changed from -2.78 to +2.78 to now -0.98.


    why these values are changing and how to resolve.

    there are no errors showing from controller side.


    checked reputability of the track its good but when robot machining is going on (ruffing) its carriage is moving approx 2 to 3 mm.

    it shouldn't be moving when robot is stationary right?


    one more thing I noticed was counterbalance sound.

    I have recorded one video also for that.


    please go through the data I am attaching and please advise.


    thank you.

  • Place your Ad here!
  • Is the robot mastered properly? Are Tools and Bases identified properly? Is robot on linear track measured in? Load data set correct? Is it accurate if you apprach points always from the same side? Correct machine data for robot and linear track? ...


    To many possibilities by just seeing the videos and pictures. Whats the robots history? What did you do to check the above mentioned issues and how exactly did you check?


    Btw. 2 to 3 mm for a robot with arm extension without absolute accuracy would not be surprising for me.


    Fubini

  • kuka kr210 L150-2 k2000

    KRC model? KSS version?

    having issues with cartesian values which robot is giving.

    A1 axis for 0,+90,-90 position gives different values for X,Y,Z.

    it gives variations while machining using track.

    What track? Is the robot mounted on a track? Is the workpiece mounted on a track? What is this track's kinematic configuration?

    for Y axis when robot is in home position its value is changing over a period of time (2 weeks approx).

    it got changed from -2.78 to +2.78 to now -0.98.

    This is in the position display on the robot pendant? Are the other values also changing? Is the same Base active when these values are recorded? Is Home position set as an E6AXIS location or an E6POS?

    checked reputability of the track its good but when robot machining is going on (ruffing) its carriage is moving approx 2 to 3 mm.

    it shouldn't be moving when robot is stationary right?

    That depends entirely on the mechanical rigidity of the track, and the amount of force the robot is experiencing. Linear tracks tend to have looser mechanical linkages than the axes of the robot arm. When using robots mounted on linear rails for high-precision applications, I often found it necessary to add mechanical brakes to the robot carriage to improve the rigidity of the carriage on the rail when the robot was stopped.


    It is possible that the track's rack and pinion gearing are worn, or possibly not meshing at the correct depth. It also sounds like the track servo is remaining active while the robot is milling. This means that the track servo is constantly fighting against the inertial and milling forces being experienced by the robot. This should be checked by applying force to the carriage both with the servo brakes engaged, and disengaged.


    Also check the $IN_POS_MA value for the track. It's possible this was set rather broadly.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners