KRC2 folder sharing

  • Hello all,


    KUKA side: KRC2 with XP Windows

    Laptop side: windows 10


    1. Setting IP address correctly on both side and can ping the robot from Laptop ,so I am sure IP addresses and subnet masks are compatible.

    2. In KUKA PC in Computer Management>>local user and groups , I created new user with these properties:

    Username: kukashare

    Password: kuka

    3. I created new folder on D:/ drive with name SRC, right click on created SRC folder and in sharing menu I shared the folder over the network with full R/W permission.


    4. And my problem: when in laptop I Enter KUKA IP address in my computer searching tab , windows credentials needs username and password. I enter username and password correctly from step two, but I can't access to shared folder because of wrong password.


    What I have done untill now:

    1. I tried to disable windows credentials but still needs correct password.

    2. I tried with other laptop with windows 7 ,but still windows credential needs correct password.


    any idea? thanks for any help

  • Place your Ad here!
  • XP was not the most secure system and since it is discontinued, it did not get relevant updates. in other words, it is still on SMBv1... which is disabled on newer OS versions.


    so to access shared folder on the XP machine, new computers need the SMBv1 enabled:

    Why Win11 cannot access shared folders - Microsoft Q&A
    Several shared folders have been set up on the old xp computer used as a shared file server.Computers of different Windows systems within the local area…
    learn.microsoft.com

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners