Background edit 4, cant end edit

  • was using remote ipandent to do background edit. since it was remote the program was being edited in BCKED4. when i go to end_edit i dont get the pop-up that you normally get asking if you want to discard or accept the changes. BCKED4 doesnt actually end that program and its not possible to select another program.

    any suggestions?

  • AD
  • Where do you "go to end_edit"? On Remote iPendant?

    - Are you able to do anything else on remote iPendant?

    iPendant may be locked in SETUP>>Host Comm>>HTTP Authentication.

    - In SELECT>>Program DETAIL, ensure the program is not write-protected.

    - Check the system variables in #UI_CONFIG.$READONLY. All three must be FALSE.

  • seems like i am able to do everything else through Remote iPendant

    checked the HTTP Authentication and its all good there

    the program is not wtire-protected, so its good on that side

    and #UI_CONFIG.$READONLY all three are false.

    im thinking maybe the pop up is getting blocked? or i am not able to see it? when i click End_edit the iPendant becomes unresponsive for a few seconds (30 or so) and than nothing else happens

  • thanks HawkME that worked, unfortunately i hit enter too many times and it selected GETDATA as the background edit and now when i try End_edit it gives two different errors:

    TPIF-054 could not end editing

    TPIF-008 Memory Protect violation

    i tried going into GETDATA program and changing Write Protect to off but it doesn't let me

  • You need to press end edit the click the arrow button over to select discard changes. Then press enter.

    It's easier to do if you can test on a different working system to get the sequence down correctly so you can do it blind.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now