Old Abb robot support

  • AD
  • Hi


    Intermittent "time out ring controller fault" works fine for approx 8 hours then fault, turn off power and rest then all ok for another 8 hours.


  • I would check the fiber optic connections between the purge unit and the robot. Carefully clean the fiber end, transmitters & receivers.

    If it still occurs, the components may have weakened with age. Try increasing the gain to the next level with the dipswitches at both ends.

  • Hi

    Fibre optic dip switches changed, still random issue. Only way to fix is to leave the robot off for a few hours then all ok.

    Any suggestions welcome.

    • Helpful

    At this point, I would be looking at the units at either end of the fiber lines and use my board repair experience to monitor internal voltages and signals. Realizing many folks don't have that capability, it can end up being an expensive game of substitution. Hard to maintain old equipment without having spare parts that can be used for troubleshooting.

  • Hello,

    "time out ring controller" error is indeed a problem with the optical cable. It solved it for me.

    My problem is that the robot does not start, "please wait stabilizing"

    writes text waiting to be purged.

    But there is no purge card and the necessary connectors are bridged.

    I also get a temperature sensor fault error, where should I look for these sensors?

    Thank you in advance for your answers.

  • It was a long time ago but i remember bridging the pressure sensor with a switch. When it purged, flipped the switch on and turned switch off after purge completed. It needs to see the transition to ensure the sensor is working.

  • Thanks for the reply.

    The problem is that this is a non-purge robot. No purge card, no sensors.

    It is possible that the temperature sensor is the only problem.

  • I've only worked on Trallfas with purge control units.

    For temperature, It's S3 design so the DC-Link & amps have temp sensors, GS power supply, mixer board, pump board, PTC on motors, terminal board has input for the auto fuses ...

  • Hello,

    I might give up, I now started the teachpendant simulation in robtalk and I can't exit it. Even after a restart, the teachpendant simulation starts.

    Have a nice day!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now