ABB S4C+ Load system module

  • Hello everyone


    I have abb robot with controler s4c+

    and I want to delete the user or base program from the robot memory and load it back into the robot

    can someone tell me how to do it?

    Many thanks

  • Place your Ad here!
  • To delete first is an unnecessary step. View modules, load module, navigate to the directory where the module is stored. Select USER or BASE, whichever is desired. Load it, you should be prompted that there there is already a module with that name, confirm to overwrite it. Done.

  • Hello Lemster68


    Thanks for your answer

    I did it according to your way but when I run the main module and once I want to use the variables that are in the base module or in the user module i get an error

    the variables I defined in the basic model were not found

  • Hello Some Tekk

    Thanks for your response

    The problem is that the program stops and I get a variable not existing error

    for example

    If I define a speeddata variable inside the base.sys file and I'm trying to use it inside the main program I get an error that it doesn't know this variable

    But if I go into the base file in the rapid folder via ftp I see all the variables exist

    my question is how can I reload the file into the robot memory

  • Look at the data from the VIEW function key. Find the one that you have created, if it is there. If you had a syntax error, it will not have loaded your module that you think is loaded. Also, you could view the module in the editor of the pendant. Make sure that it is type PERS or CONST.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners