Yaskawa yrc1000 conveyor tracking basics

  • Hello All,


    I'm new to yaskawa and I'm setting up a line tracking system to simply set and wait for a mold to come by then follow the mold and dispense foam in it while the conveyor it moving. I only have one trigger sensor and I need to start following it when my trigger is made. The track is constantly going the same direction so I'll need the robot to go back to the start position when the next part trips the trigger and follow the speed again.


    It appears to be tracking but not straight across. It moves on an angle sometimes.


    I feel like it has to do with my lack of understanding with the conveyor calibration. I've taught different points like a frame there but it tells me they are all the same. Then I try moving the encoder and teach different points it sometimes takes it.


    Any help would be greatly appreciated.

  • HI all, I'm testing conveyor function with motosim. I try to trigger 40700 to simulate several cycle but it can't reset Conveyor position. Is there any way that I can reset it?

    Thank you.

  • first thing is that conveyor is reset just with SYEND command.

    I'm not sure if you can trigger the conveyor again with 40700.

    Um looking for this solution too.

    There is a quick pick simulation example with many parts but it use position variables, so no multiple triggers for conveyor

  • For the project I just did I used a pounce program to call when my application program was complete to put me back over my conveyor. After your sysend you can create a condition to call the pounce program. Or Call you application again. Plus in your job setting there's a spot that allows you to select step, 1 cycle or auto. Auto will bring you back to the beginning of whatever program your running. I forget where that is tho

Advertising from our partners