System Ladder - Sequence Wait

  • Hello,


    Currently working on a MOTOMAN Yaskawa GP25 robot with a YRC1000 controller. I am attempting to modify the Sequence Wait rung in the System Ladder section, which I have done previously on 2 other robots with the same controller. The robot/controller is for a general-purpose application.


    I am using a general-purpose input (00315, light curtain) from a PLC output and inserting that into the User Ladder section connected to auxiliary relay 70500 (output). I am then saving the program, adding an OR rung to the OUT #40130 System Ladder rung offline on my laptop, and then reloading the CIOPRG.LST program back into the controller.


    The 2 previous robots I have worked on, I did this exact same operation on with no issue. The issue with this current robot is that every time I modify the CIOPRG on my laptop, those changes never apply to the controller when loading it back in. There is a certain way according to a MOTOMAN manual to correctly load a changed CIOPRG back into the controller, which I have done. I understand that I can tie the 00315 input in the User Ladder to the 70030-70033 outputs and adjust the 5008x specific outputs to enable the sequence wait at any time and adjust those specific outputs to be ON at all times, but just wondering if anyone has had this trouble before?


    Current System Ladder example:

    STR #70030

    AND-NOT #70034

    AND #50080

    STR #70031

    AND #50081

    STR #70032

    AND-NOT #70036

    AND #50082

    STR #70033

    AND #50083

    OR-STR

    OR-STR

    OR-STR

    AND-NOT #50063

    OUT #40130


    Modified System Ladder example (adding in auxiliary relay 70500):

    STR #70030

    AND-NOT #70034

    AND #50080

    STR #70031

    AND #50081

    STR #70032

    AND-NOT #70036

    AND #50082

    STR #70033

    AND #50083

    STR #70500

    OR-STR

    OR-STR

    OR-STR

    OR-STR

    AND-NOT #50063

    OUT #40130

  • AD
  • There is a certain way according to a MOTOMAN manual to correctly load a changed CIOPRG back into the controller, which I have done.

    The certain way being through Maintenance Mode?


    What software version is being used? I don't remember this being available when the YRC came out. Can't find anything in my notes (I'm sure I read this) but could it be the controller this is failing on has an older software version?

    I know a thing or two, because I’ve seen a thing or two. Don't even ask about a third thing. I won't know it.

  • The certain way being through Maintenance Mode?

    Management Mode just on normal power-up. It states this in the YRC-1000 Options Instructions For Concurrent I/O document, section 14-4.


    And the controller unable to load the changed system ladder seems to have a newer system version of YAS4.32.00A (Parameter 3.72/3.72), while the other 2 that have worked have a system version of YAS4.30.00A (Parameter 3.77/3.77). Not sure if that would be the issue. I was also not the programmer who began to first program it, so I will check through the initial settings and see if I can find anything that could fix the issue.

  • The only difference I have noticed also booting it up in Maintenance Mode was the system version and also that the MotoPlus Function was enabled.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now