VMware and WorkVisual

  • Hi,


    I have problem to connect to the robot with WorkVisual V6.0.21 installed on wirtual machine (VMware).
    Host: Win 11
    System with WorkVisual in witual: Win 10.


    I tryed all options on "Network Adapter" configuration.

    1. NAT

    2. Bridge
    3. Bridge with replicate physical network connection state


    I tryed also with external wifi card.


    When I ping robot then I receive feedback from the robot but in Workvisual I don't see this robot.



    In host I dont have any issue with connection to the robot.


    Did someone have problem like this?


    Firewall in Host and Wirtual are disabled.

  • AD
  • lots of people have problem with connecting to robot even when WoV is installed on the host OS. when working from VM there is an added layer that need to be managed.


    example of problems are:

    1. connecting to wrong port. make sure that you read the documentation and know for sure which RJ45 you are connecting to.

    2. not understanding network addressing. IP address and mask need to be matching or there can be no connection.

    3. not understanding difference between DHCP and static addressing

    etc.


    an easy way to spot someone who is just chasing own tail is when they ask for help without mentioning details of connection and settings that they tried. they do not mention how to replicate their steps. they do not mention what troubleshooting options they tried or what experience level they have.

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • Hmmm riiiiight... writing just for writing is no sense....


    I have connected router (router mode - dynamic IP etc.) to the switch inside robot cabinet (i'm to lazy to walk around all robot and connect one by one).


    Host network card also automatic settings.... and in Host I see all connected robots and I can open each project in WoV. WITH THESE PARAMETERS.


    But...when I open WoV in VM then WoV don't see the robots but I receive feedback after pinging in CMD.


    Also when I scan network with Proneta then I see just Host.


    If you didn't had these situation OR you don't know how to help or show some trick don't loose your time...

    Edited once, last by Lysy ().

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now