Password required every time

  • Hello all.

    I am using KUKA KR 210 R2700 2 F

    With KR C4 Controller.


    After turning robot mode from EXT to T1, I need to give password every time, to value any output or change in program. Or any other activities.

    I am facing this issue only with one robot, I have too many robots in my company,but they did not required password to do any activities like turning output on or change in program.


    Please guide me. 🙏

    Thanks in advance..

  • AD
  • Which KSS version? Were all the robots setup the same way at the same time?

    I believe in KSS 8.5 the default user is not allowed to trigger any outputs, but that can be changed via the menu, which user is allowed which functionalities.


    Usually, the default user should not be able to change anything, as you do not want someone walking by to start making changes.

  • Lookup forum search with keyword Authentication.config. Mostly anything concerning access change can be configured in there. Also a look into the rights management menu might be useful. Changes here need administrative priviliges.


    Fubini

  • After turning robot mode from EXT to T1, I need to give password every time, to value any output or change in program. Or any other activities.

    When you switch modes, are there any messages similar to "User group changed to {Operator}"?


    Usually, this "downgrade" in the user group happens when switching from T1 to EXT or AUT -- default KRC4s typically do this. But not when switching to T1.

  • I just want solution of :

    Why everytime greater login required to force an output.

    Can we turn ON & OFF outputs in default(operator) user group ??

  • Also a look into the rights management menu might be useful. Changes here need administrative priviliges.


    Fubini

    I checked inside Rights management option.

    But I did not satisfied there, still my problem as it is.


    In T1 mode, and in operator user group, i want to turn OFF & ON digital outputs, but the value option is not usable/blurr,

    Value option appears after turning greater mode than operator.& password required every time.

  • The key here is probably that the value setting requires expert rights. If this is the case to change this either there is an option in the rights management or you need to set your controller to be always in expert mode by authentication.config. You said yourself you have controllers where it works. So compare rights managements options and authentication.config between working and non working controller. You could also create a KRCDiag of both controllers and file compare them. Maybe you can find a difference that contains a hint e.g. in smarthmi.user.config or other files.


    Of course you can also open a ticket in kuka support.


    Fubini

  • I got it :saint:

    There is an option available, "General Configuration" In Start up > Rights management.

    I just changed its Rights management to 'Operator'

    & I got as I required.

    Now I can directly ON / OFF outputs in T1 mode without changing user group each time.

  • Ok. So both controllers probably run different software versions. So of course stuff can change from version to version. Rights management has not been availabe for ages. I think it was introduced with 8.5 maybe late 8.3. It is too long for me to remember in detail. So you have no 2 controllers were its working in one and not the other one with same software. These are details that matter but you do not mention. Windows 10 is not the same as Windows 95! But anyways already 3 other solutions were proposed you did not check out:


    1. Compare KRCDiags for a hint into the correct direction
    2. Use authentication.config for always expert mode
    3. Contact KUKA customer support

    I think thats enough suggestions before comeing up with new ones again.


    Fubini

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now