Disabling ethernet errors does not work for Ethernet KRL 3.2

  • Greetings


    Robot controller: KRC5

    KSS: 8.7.4

    Ethernet KRL version: 3.2.7


    My robot is configured to be a server that receives data from another robot (figure 1). The server program runs in submit interpreter in order to respond to requests swiftly (figure 2). Everything works fine for an hour or so until some error messages ("Initialisation already performed", "Create server failed", etc) pop-up on the top of display. When the error messages are cleared from the display, the connection is automatically restored and program proceeds to work correctly again.


    I have not encountered an error message in testing that leads me to believe that something is systematically wrong with the robot program. Rather when reading the EthernetKRL manual it seems that encountering some of these errors is to be expected (figure 3). So I would like to deactivate the message output on display. I have tried the following options:

    1) Disabled messages in EthernetKRL configuration file (figure 1 again, <MESSAGES> tag)
    2) Added ON_ERROR_PROCEED line right before any EKI function call (removed from the program after testing as they didn't do what was intended)

    So far both of these options have not worked as the EKI errors still appear on the display. Am I disabling the ethernet messages wrong? Are there any alternatives to automatically clear these EthernetKRL errors when they occur?


    Regards
    Jürgen

  • AD
  • 1. You can attach pictures direct to the post, so we don't have to waste time downloading and unzipping.

    2. It sounds like you open and close the server frequently, I would open the server once, and then listen to messages in a loop.

    3. Think disabling messages does what the name says, it disables the messages, but doesn't disable the fault, the fault will happen anyway, but you don't get a message about the fault.

  • you can also embed code in the posts in the text form. this is config from one of projects using EKI as server in submit. note that logging is enabled because i still want to know about any issues, just do not want them displayed.

    i also like to open connection and keep it open... and only react when connection is lost. that could be sensed with ALIVE flag.

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • Will follow your guidelines for posting from now on.


    Okay, I will try to react to the alive flag when connection is lost. Found a piece of code in the manual that achieves that using interrupt. With a few modifications this could work.


    In response to hermann: So you're saying that even if I succeed in hiding the EKI error message from the display the program would still stop? I thought hiding the EKI messages would lead to behaviour similar to pressing the Confirm button, where the program continues executing (this is what currently happens when I press Confirm).


    (For reference, usually I wouldn't need to open and close the server that frequently when dealing with KUKA to KUKA connection. However one of the older ABB robots seems to drop the connection from time to time)


    Jürgen

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now