mxAutomation communication issue with OPC

  • Hi everybody,

    I'm reporting an issue when using MxAutomation_UDP_Server app. I send a Messages, but I don't recive data from roboter.

    I'm trying to connect to controller from a PC via UDP and it should be an easy task using the packages provided by KUKA.

    But it seems like ProConOs don't have a source adresse.

    Some infos that may be useful:

    WorksVisual 6.0.15

    mxAutomation V2.1.6

    ProConOS 4-1 4.1.5

    Communication between PC and OPC is OK - The KRmesgNET packages (see KUKA.PLC mxAutomation 2.1, page 15) go in both directions without any problems.

    Any suggestion will be appreciate. Thank you.

  • Are you using an Officelite or a real robot?

    Have you turned off the firewall, which could possibly block the connection?

    To use the UDP MxAutomation connection, you have to enable this signal in mxa_config.dat.

  • Hello Ben,

    thank you for your answer.

    Yes, i set MXA_COMM_MODE to 1 and change gmxA_MAX_UDP_Timeout to 1000 ms.

    I also set PORTS 9050, 1337, 1336 free in the Windows Defender Firewall.

    I will check our Switches, but i think they are OK. Because the KRmesgNET packets (UDP) go in both directions without any problems.

  • Hello,

    i tried send/receive direct with OPC per mxAutomation UDP. Wireshark show me the packets=> Packets go until Windows, but ProConOS Net Module in diagnostic show recieved 0 packets!

    I think the problem is in KLI configuration. Filter??

    Must i extra Filter for UDP make?

    • Helpful


    I have solved the problem! Namely, my mistake was that I have NATs inserted in network settings for ports 1337 and 1336 - but must not do that!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now