TP Alarm Text MSG to CompactLogix Has Extra Characters

  • Hello All,


    I using explicit messaging to get the most recent active TP alarm text to my PLC. Settings for the MSG instruction all seem to be correct, but I'm getting extra characters on the leading edge of the string coming from the robot.


    Screenshot of MSG settings used is attached.


    Resulting string text looks like this:


    'O$00$00$00SYST-045 TP enabled in AUTO mode '


    I have to guess that this is an issue with the way the string data is formatted by the robot, but I'm fairly new to working with Fanuc at this level so any help would be appreciated. Is there a way to remove those leading characters through messaging settings on either the robot or PLC side, or just manipulate the string in ladder logic?


    TIA

  • AD
  • Odd. Looks like you have everything setup correctly. You are writing into a STRING tag, and not the data portion of it right?

    My hero!! Just checked and I was indeed writing to string.Data[0] in the MSG. Rewrote it with simply the STRING tag and it worked perfectly. Can't believe I missed that...thanks!!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now