IRB 4600 IRC5 dead after switch from auto to manual

  • hi all, im quite puzzled by what happened to our 4600 IRC5, 1 year old, about 100hours of light use.

    This morning after a project under EGM control, i switched back the robot out of Auto to Manual mode to jog it into a parking position. I turned the mode switch while the robot was still Motors On, and immediately got a fault “34257 Open circuit in bleeder resistor circuit”. I acknowledged and tried to enable motors for jogging and nothing, same error. I restarted the controller, no error but as soon as i enable motors for jogging the 32A fuse of the electrical cabinet pops and the controller instantly shuts down.

    So 2 questions:

    - there is absolutely nothing in the operating manual mentioning that the robot has to be motors off to do a mode switch, and if it could literally fry anything by simply mode switching during a run there would likely be tons of people sadly discovering it like me, seems to be that the controller should be able to go motors off just like you release suddenly the deadman switch. Still, is it considered proper procedure to always manually go motors off before switching mode?

    - did this happen to anybody else? Is it a common thing? For a brand new robot to go dead on me by simply switching mode has made my confidence in it plummet since its meant for film production use and luckily it died at the end of a shoot and not at the start with a whole film crew and angry producer in the studio..

  • Place your Ad here!
  • First - I've switched the keyswitch from Auto with motors on to Manual literally thousands of times without issue. ABB did away with the motors off switch many version ago.

    Does the fuse open when the deadman is first pulled in or when the the joystick is moved?

  • Uff, ok yes i also thought it would be crazy that its against procedure.

    Fuse opens as soon as i depress the deadman switch, seems to be before the motors are even on since they dont even release brakes like when you start moving the joystick. From what i gather there was this bleeder resistor circuit error right after, with a warning that the dc link will stay energized. So i suspect that something must be shorted out or something, its pretty much impossible to troubleshoot further since i cannot get any error log as it abruptly goes off. Ive called ABB support, let’s see.

    But good to know that there was nothing wrong on my side, i couldnt believe it would just go out on a mode switch..

  • Assuming the fuse is an incoming voltage fuse to the controller, is it the same phase each time?

    Double check incoming voltage is correct on all 3 phases and connections are good at the back of the controller disconnect switch. I like to measure incoming power with a low impedance style device like a wiggy as the high impedance of a DMM will give false readings.

    Which controller design is this? A pic of the inside will usually tell?

  • hi Skooter,

    I will have access to the machine only next week again, but this is a brand new IRC5 robot, manufactured in 2021 so I assume "latest" controller revision. What I am confused is that everything was working smoothly for the entire morning, and the only change was going from Auto to Manual, so i doubt that something would have happened right when i switched it. I will go check the incoming power once I'm back there next week to make sure.

    When you mean is it the next phase each time, do you mean is the power connector wiring changing or something? We always use the same power connector, same we used many times before without any issue.

    Only smoking gun I have is this screenshot of the TP log showing the manual switch, and then few seconds later the error once I tried to jog it. From then on I could not do nothing so I initially assumed some benign safety warning, like on our S4C+ it would give off warnings when the enabling device was just slightly depressed and only one safety channel would trigger too early from the other. But after restarting the controller (just a warm start) then it simply goes out everytime the enabling switch is depressed.

  • I obviously dont have a robot to test again, but when switching from Auto to Manual, shouldn't the "Motors OFF" state message be seen right after the "manual mode selected" message? There is 18s between the manual mode request and motors OFF state. Is that normal?

    From my memory the motors should go off right away no? I cannot remember if they did go OFF when I switched, so I might just be wrong, but I was not pushing on the enabling device so it just seems weird that the motor OFF would be so delayed, am I mistaken?

  • Per the IRC5 product specification, the recommended line fusing is 3x25A for 3-phase 400-600V on a 4600, (we are running it at 3x400V).

    We've never had any issue whatsoever related to fusing before, only once with differential earth protection on an electrical install with 40mA protection, but most times it's been fine on 40mA. (mind you we run the robot for film productions in studios and on-location so most of the time it's a huge hassle to make the studio/client change their electrical install the day before a film shooting, the IRB4600 is specified as running fine on 40mA if no more than 7m long motor cable is used, above that and a 300mA protection is required). Anyway here it's the fusing that pops so unrelated.

    Wouldn't the fuse have been popping way before when we did high-speed high-load movements? Here it's popping even when standing still with motors off :frowning_face:

  • I didn't say next phase, said same phase each time.

    If you are weak on 1 phase, it may draw more power on the other 2 phases. Seen this dozens of times over the years.

    I would be remiss if I didn't ask you to check incoming power first. Checking incoming power is the fundamental first step in electronics troubleshooting.

    Once you establish incoming power and connections are correct, then look for pinched wires or issues with DC-Link, Cap Bank, amplifier, etc.

  • Ah ok I see now why I was confused, sorry: it's a tripolar circuit breaker so I cannot tell which phase trips it.

    I have only access to the location next week and will have an ABB tech coming to look into it, will report on their findings.

  • Update after ABB technician intervention:

    The DSQC 663 unit was dead, swapped for a new one and all smooth sailing.

    Tech guy confirmed there was nothing wrong with mains supply nor did we do anything wrong, sadly the dead unit will go back to ABB for repair and enter refurbishing cycle without any chance to know what was the actual failure.

    The problem seems to have been bad luck.. maybe manufacturing defect or something, the robot is 107 hours only.

    Luckily we were still 1 month under warranty left so that has not been as stingy as expected, ABB replaced the unit at no cost for us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners