SRVO-050 Collision Detection

  • I have a Fanuc R2000 with a 7th axis. During the process the robot is stationary while the track is moving. On a couple occasions I have seen the Axis 5 disturbance value slowly increase to the point of collision detection. This is over a 2.5 hour period. As soon as the robot is moved the current "unwinds" and returns close to zero.


    I have adjusted my collision sensitivity to increase the threshold,

    Fine tuned my payload data.

    Looked into turning on the brakes, but all axis are on the same group so I cant just disable A5 while its not moving.


    Any suggestions?

    I could try to move the track and the robot a little to keep the robot axis turning so this issues doesn't pop up, but it seems like a Band-Aid solution

  • AD
  • You could try disabling brake hold on that axis. By doing this you force the robot to hold position with the motor powered rather than enabling brakes after a set time period. Go to variable $PARAM_GROUP > MRR_GRP_T > MRR_GRP_T > SV_OFF_ENB then scroll down to number [5] and change from TRUE to FALSE. Then cycle power. This worked for me in a similar situation years ago.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now