Using KUKA.SafeOperation and avoid

  • Hi all.

    I am using KUKA.SafeOperation 3.6 and have defined my workcell as shown in attachment. These covers in real life different conveyors and gantry with sensors - i.e. pure mechanical stuff, that I want to protect in case that operators someday take the TP and jog the robot manually around. Then I have these restricted zones, which is always ON and hence the robot can not manually be jogged into mechanical obstacles. The other major point of using this, is in case that somehow the system stops, and operator is calling cell.src from a random position, I want to ensure that the robot will stop before colliding into obstacles. There might be a better way to move the robot safely back to its home position, I honestly don't know, but I just saw in an other projects that the main program of the PLC was re-initialized and then requested robot to move to its homeposition with result of sending the robot back to home position through a tool rack and made a major collision :thinking_face:

    Therefore when buying the robot, I also added the KUKA.SafeOperation - just in case, to try to avoid this kind of situations.

    Anyway, now I have applied this KUKA.SafeOperation and it works OK. After working with KUKA.SafeOperation I found it to be not that well suited for this task, i.e. only protecting for mechanical collision, because I will be driving fast to different conveyors. I think KUKA.SafeOperation is better when you have larger distance to your objects in the cell and want to trigger the zones ON/OFF, when people need to access the cell.

    Anway, just to explain the robots task: The robot will take obstacles from a pallet section and place the obstacles to other conveyors. See 3D simulated world below:



    So, what is my problem really? :smiling_face:

    My problem is, when safe monitoring is enabled, is that when I am getting close to my different protected zones, the robot starts to slow down. I.e. the acceleration and speed are reduced - which causes cycle time loss. I get this warning:
    "Safe robot override reduction active - KSS00470".

    I would like to still be able to run as fast as possible with the robot, so I was consulting the manual.

    What I found was that, I could disable this feature, (I guess), by setting $SR_VEL_RED = FALSE, but this flag is located inside the MADA, i..e machine data.

    My question is then : Is this "safe"/OK to start changing, or is it totally no go to start modifying the machine data, i.e. ;KRC:\STEU\Mada\$custom.dat

    Anyone that have other nice experience using KUKA.SafeOperation?

    Another idea was to shrink the volume of the different spaces, but then they do not protected the mechanical conveyor, sensor gantry etc and then the hole point is wasted. And I am not able let the robot move in a larger distance away from the protective zones, because I need to get close to e.g. a roller section with the robots tool in order to get the obstacles and move them to an other pallet section. E.g. in one situations I am like 5 mm of space between the tool and the roller of a conveyor.

  • My question is then : Is this "safe"/OK to start changing, or is it totally no go to start modifying the machine data, i.e. ;KRC:\STEU\Mada\$custom.dat

    You are allowed to change values here. The avoidance functionalty slowing down robot are non safe and done only in the none safety qualified parts of the robot controller.


    Fubini

  • Hi I tried to turn it OFF but now I get E-stop triggered by safety controller. 🤔 So I guess that I should just limit the workspace in other way.

    My current system contains the following information:

    • Robot: KUKA KR50 R2100
    • Controller: KR C5 dualcabinet
    • KSS 8.7.2 HF3
    • HMI version: 8.7 B394
    • Kernel system version: KS V8.7.53394
    • WorkVisual V6.0.24_Build1632
  • Thats new. Never heard those two are connected. But might have changed since last time I had contact with this stuff. Or do you mean when executing your robot trajectory you get no longer slowed down and then velocity is higher than allowed velocity in your system state. This can of course happen if you are to close to a restricted zone. The software internally estimates each calculation cycle the brake distance for the current system state. If the estimated position where the robot would reach velocity zero is inside a forbidden zone a safety stop is triggered.


    There is a option in safe configuration to only trigger the stop if forbidden zones are entered and not beforehand using the brake estimation. Do not remeber the exact wording there since its been quite a while ...


    The checked positions are defined by the tool spheres. So moving them around and therefore moving them away from the forbidden zone can help as well. If chosen to big also could be a problem at least if chosen bigger than covering the tool geometry.


    Fubini

  • Yes the last thing, i.e robot was moving without speed reduction which triggered something in the safety controller and initialized dynamic braking.


    Anyway, I might swap KUKA.SafeOperation with just limiting the robots workspace. There I discovered that I can define up to 8 cuboids, which are not safety related, but that do not matter in my case, because the robot can not reach the safety fence, including the reduced distance due to that the safety fence is made out of grids, not polycarbonate.


    So again all I want is to have a limited space, where my mechanics like pallet conveyors are not damaged if someone makes a wrong position or use T1 wrongly.


    So these workspace limitation seems to be the way to go, but I am not sure how this works, when there is only one TCP and not as in SafeOperations the possibility to define a lot of spheres of your tool. So I guess there will be some sort of manual work to use the standard workspace limitation, I guess.


    Inputs/comments are really appreciated 😊👍

    My current system contains the following information:

    • Robot: KUKA KR50 R2100
    • Controller: KR C5 dualcabinet
    • KSS 8.7.2 HF3
    • HMI version: 8.7 B394
    • Kernel system version: KS V8.7.53394
    • WorkVisual V6.0.24_Build1632
  • Workspaces aren't usable for your task, as they only check the tcp, not the entire gripper.

    I never use safe operation for protecting devices like conveyors, only for humans, that's what it is intended for.

    For the restart of the program and moving the robot without collision there exist many examples/threads here in the forum.

Advertising from our partners