Inherited pack and go, simulation works fine after rotating tools, rapid program doesn't even after synchronizing

  • Hi all,


    I've inherited a robotstudio cell.

    The guy who sent it to me attached the 3D clamp to the robot for me.

    This said, yesterday I went to my customer and I've noticed the robot was moving in a very strange way... the tool was wrong mounted into the robot (rotated 60º).


    SIMULATION PART

    This morning, back in the office, and in robotStudio, I detached the tool from the robot.

    Exported it to a 3D part, imported the 3D part again, moved that 3D part to 0,0,0 and rotated it 60º.

    Created 2 frames (one for each tcp (it's a double clamp).

    Created a tool using those frames.

    Attached the clamp to the robot again.

    Executed the simulation paths and the robot (with the rotated tool) moved along the path perfectly fine.

    That part worked well...


    SYNCHRONIZATION PART

    After all this, I deleted all the related data from the old rapid programs, calib data (tooldata stored there) and Module 1 (simulation paths stored there).

    And synchronized the simulation to RAPID to regenerate all the paths and tools.

    If I execute the paths in the rapid program while seeing the graphical window, it shows the robot moving across the paths, but with the clamp rotated as it was before.

    Which should not happen.


    Am I missing any step? Have you noticed this before? Do you know how could I solve this?


    Thank you in advance.

  • AD
  • Solved:


    ABB service asked me a pack & go.

    I've sent it to them and they called me telling they could not see any difference.

    We've checked together and it worked in my computer too.

    So I have no idea why it started working fine, but I'm glad it does now.


    So no nothing to see here...


    ^^¡

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now