unable to load POSREG.VR and SYSVARS.VR after installing "Independent Axes" and "Multi-Group Motion"

  • Hello,

    after some months of R&D I decided to create a servo-gripper for one of our robots with a fanuc servo motor directly attached to the gripper of the robot. Long story short, we had to upgrade the software suite with Independent Axes and multi-group motion so fanuc asked for an all-of-above backup of the robot and an image backup also and after some days they sent us back a modified image with the needed software.

    The idea is that after upgrading the robot with the new image sent from Fanuc reloading the all-of-above backup would give us a working robot just as it was with the addition of the new software. Image installs fine, robot upgrades controller firmware and tp firmware, everything goes as planned and after the image installation I do an Init start and proceed to controlled start to load my old all-of-above backup to load my registers sysvars tcps frames programs etc etc.

    When the restore procedure hits the posreg.vr file though, it prompts a message if I want to convert the file and shortly after hitting yes it reports an error "array mismatch" and proceeds with the next file. Same happens with sysvars.sv file.

    Digging a bit more into this and with the help of roboguide I discover surprised (=because it should have been obvious to me from the begining) that in the new software the position register structure has changed from
    PR[...]: [GP1]:{x:..., y:..., z:..., w:..., p:..., r:...}
    PR[...]: {[GP1]:{x:..., y:..., z:..., w:..., p:..., r:...},
    [GP2]:{x:..., y:..., z:..., w:..., p:..., r:...}}

    and I guess this is the array mismatch that doesnt let the system convert the old posreg.vr file. Is there a workaround to this other than the obvious of manually filling every coordinate value on 118 position registers ? even if I get in all this trouble for the posreg.vr file I can't do the same for the sysvars.sv file as there are so many variables I had changed that I can't remember.

  • I would have suggested installing a PAC instead of new image, then you wouldn't need to reload any files. There's likely nothing you can do now besides ask Fanuc to convert for you.

    This is what I asked from the begining but this is the standard procedure used by Fanuc Italia. They don't use PACs. They only provide new images when you wish to add a new software option.

  • PACs are still used, just not by regular customers, like you and me.

    Customers outside (north) america don't get load media with their robots.

    Any time new options need to be installed, only Fanuc can do that. They do exactly as ps0f0r describes: take an image backup, perform a procedure similar to how roboguide reserializes a robot and then send the image back.

    This still uses PACs, they just never get to customers directly.

  • If you post your posreg.VA file, I may be able to help. I have a Karel program for this exact situation.

    even if we do this for the POSREG.VR SYSVARS.VR has thew same array mismatch problem. I am still waiting an answer from FANUC tecs. They still haven't offered a solution.

  • They won't have a solution, I've been down that road before.

    System variables are way easier to manually recover than position registers. Anyone can try and type in all 708 independent real numbers for your 118 posregs. Anyone and everyone will fat finger at least one of those values. Bad position register = robot crash.

    Sysvars on the other hand will likely just be a nuisance. Something won't work quite right and then you'll remember that you had to change something. I guarantee you didn't change anywhere near 708 different system variables.

    What is your software version?

    Do you have Karel?

  • Update on the matter:

    Forget about being able to load all but sysvars.vr and posreg.vr.

    After the installation of the equipment hardware (aux axis servo amplifier and motor) I proceed installing FANUC_IMG, image installs fine, I am also able to Start COLD on a fresh system, but trying to restore the all of above backup and then START COLD system hangs before booting the operating system with a black screen. Fanuc Rotational logo never displays. If I force a power restart when in black screen, system starts booting, FANUC logo appears, and after 20-30 secs I get a robot page error "Controller startup timed out". I also tried an INIT START (as suggested by FANUC) before restoring the all of above backup but to no success...

    Digging a bit through the matter, I came to the fact that 3 files are responsible for crashing the system: SYSVARS.VR, SYSSERVO.SV, SYSMASTER.SV. Loading any of the 3 files causes the controller to crash and not load the operating system. I know I can live without SYSMASTER (and even SYSSERVO maybe) but not without sysvars.

    Fanuc has no clue as to why this is happening, they never faced such a problem before and they are very skeptical about it. They say there is no problem between new image containing a newer version than the previous controller version I was already running and system should handle the conversion of the files fine.

    Tommorow I have a video call with one of FANUC Italia's chief techs concerning the matter. He wants to run some tests.

    Of course, POSREG.VR refuses to convert (I mean even if I skip those 3 system files I mentioned)

  • Of course Sysvars will not load. You changed your hardware, the old variables won't work with the new hardware. There is now a new array for each system variable for the new motion group.

    I've been down this exact road before. Fanuc will not have a solution.

    Again, if you want help with posreg.vr, just let me know.

  • Of course Sysvars will not load. You changed your hardware, the old variables won't work with the new hardware. There is now a new array for each system variable for the new motion group.

    I've been down this exact road before. Fanuc will not have a solution.

    Again, if you want help with posreg.vr, just let me know.

    yes, yes I dont forget about it. I just want to see where the FANUC road leads. They strongly insist the backup restore process should finish and cold start regardless of the conversion problem.

  • Thank you all very much for your help.

    FANUC finally agreed to send me a new image containing the AOA backup with the correct files. I am still experiencing minor issues compared to the robot behaviour with the old software (mainly constant path and CPMO errors) but I can live with them and I am still investigating into what's changed to cause this weird behaviour (Constant path is disabled but I still get errors concerning CP) but all in all it is back in working condition with all the old files loaded.

Advertising from our partners