OnRobot gripper error

  • Hello,

    I have a pick and place operation with a UR5e and OnRobot gripper. I randomly receive an error from the gripper using RG Grip command in normal operation.

    The error is:

    RG Grip command returned with error. Please be sure the required width is between the limits. Program halted

    I’ve seen that the error is generated most of the time when the gripper is without the product and there is a new command to open the gripper. The width for opening is 100mm (maximum for the gripper is around 140mm), force 25N.

    I used the RG Grip command from the instructions menu and also the next line code rg_grip(100,25,rg_index_get()) and I got the same error.

    The gripper is RG6 with direct connection on tool flange.

    The URCap OnRobot software for the gripper is version 5.15.0 (we also tried 5.10.0 that was on USB Stick at delivery)

    The robot’s controller is OEM Control Box with URSoftware 5.11.0.108249.

    Would you offer me some additional information about error message and what should I check?

    Thank you!

  • Place your Ad here!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners