[solved] KCP not responding, External Emergency Stop, Local Protective Stop, Safety circuit for drives not ready

    • Helpful

    Hi,


    Recently I managed able to revive some long-time retired Kuka robot.

    Fortunately for me, I have my hands on some spare parts for KRC2 controller.

    I would like to share my experience with solving those issues, maybe someone will find it helpful.


    Patient data :

    - KUKA 200 comp

    - controller (V)KRC2 ed05, KSS V5.4.14


    Error messages :

    - KCP: connection error WATCHDOG_ERROR

    - Local Protective Stop (QE)

    - EMERGENCY STOP

    - External EMERGENCY STOP Pressed

    - Safety circuit for drives not ready

    - Drives contractor off

    - Accu voltage at PM1 below 22 volts during last buffering


    Visible symptoms :

    - KCP buttons not responding (including mode selector and E-Stop). When connected external mouse and keybord it's possible to operate KCP.

    - 2 red LEDs on KPS 600 are shining with still red light


    What I did:

    - replace all possible fuses - no result

    - jumper X11 plug for standalone operation - no result

    - replace KCP - no result

    - replace MFC3 card - bingo!


    After replacing MFC3 card, red LEDs on KPS 600 are blinking rapidly, all buttons on KCP are responding, and there's no error messages left.

    KPS 600 after replacing MFC3.mp4

  • AD

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now