External hold

  • Hi,


    I have problems with commisioning old HP20 NX100 robot.


    I have external holding signal, but do not know how to solve it.

    Servo ON is OK, but robot does not want to move due to HOLD signal.


    It looks like system ladder is not standard.

    External hold comes due to 40067. It is enabled due to 00200 which is off (should be on).

    00200 comes from 20220 which I do not know from where it comes.


    In the user ladder there is 80024 that makes out 70010.


    I also can not change user ladder. It says it can not edit on the present user lever (but it is management mode). There is only one higher level but I doubt that it is needed for user ladder.



    Kind regards,

    Ales

  • Place your Ad here!
  • I also can not change user ladder. It says it can not edit on the present user lever (but it is management mode). There is only one higher level but I doubt that it is needed for user ladder.

    Your line (the only one that I see with the ORNOT 00200) is under SYSTEM LADDER PART, so you cannot edit it.


    There's a procedure to load a different system section of the ladder, but I don't remember if it's available on the old NX100.

  • Can you tell me more about how to make by-pass?


    Another problem is that I can not change user ladder in TP as it says: it can not edit on the present user lever.



    Robot was a part of network (connected to PLC over Profinet-Fieldbus)m now it will be used for low budget handling without Profinet connected.


    Best would be to throw out Profinet card and sell it f somebody needs it and use integrated I/O signals from CN7 to CN10. For safety I would use MX card.

  • I have corrected user ladder offline and wanted to upload back to TP.


    I have added

    STR-NOT #20022

    OUT #00200


    Didn't go through due to OUT #00200 allready used as OUT in the ladder.


    So, how can I make bypass.

  • Again I've downloaded your CIO:

    all the instructions are written in the system ladder part (not editable).

    You have only a STR #80024 OUT #700100 in the user section.


    From DX100 controller or newer you can edit offline the SYTSTEM PART and reload through CF CARD.

    So you have a try writing offline( overwriting the existing system part) and then load the CIO from CF CARD.

    If you write those line in the user part you have the error above.

    Code
     STR-NOT #20220 (instead of STR #20220)
     OR #11190 (same)
     OUT 00200 (same)

    ----- BUT --------

    - Also you have to understand what the 00200 is doing with the register M005 (line 667) and with the output #75000(line 618).


    - #20220 is an external signal (probably coming from a connected PLC) that will activate the HOLD.

    The HOLD is used for safety reason, you must be VERY CAREFUL with that.

  • Thank you for a reply.


    I tried to change the Ladder as you suggested.

    It gives me ERROR 3160 Cannot load illegal system data


    Is there any other option?

  • I don't know other options.


    Keep in mind that the procedure of loading a different system section part is a little bit complicated than simply loading the CIO. I don't post it here (even if is easy to find in the manual) because it is not a safe operation modifying the system ladder part.

    However as I said in the previous posts I know that is only available from DX100 or newer.


    My hope was that in the older controller a simply offline editing should have solved your problem, but it doesn't work.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners