Waking up 2 - ZZX200S B Robots after long hibernation

  • Hello Forum,


    Attempting to wake up 2 robots that have been dormant for many years (~10). Formerly they were used at a community college but little is known about their origin. I have done my best to review similar posts and instructions but haven't found a situation where no backup files are available. Robot information is in the below table, attached are the robot.as, alldata.as files which I pulled down using KRterm and RS232 (I have ordered a 32mb PCMCIA card - wouldn't read 256mb).


    What I have done thus far:

    - Replaced batteries on KA/1RA board and at base of robot

    - Booted robot which hung up at "Simple Friendly" screen

    - Switched dip switches 1 & 8 on and rebooted

    - Chose reinitialize

    - Pendant progresses to main screen with numerous errors:


    UASR2E1040Z

    2008/10/14 14:05


    <D2023>Failed to load arm data.

    <E1009> No 1 I/O board is not installed.

    No = 1 Robot name: NOT SETTING Num of axes 6 Serial No.1

    >Cleared Error State

    <D1017> Download error of servo data.

    <D1016> The servo data file does not include available servo data.

    <E0903> Check sum error of system data


    Current Setup:

    Right now, one robot is setup for spot welding and the other with a gripper (though has hardware for welding gun). I have only powered up the robot with the spot welding attachment. My goal is to use them as basic material handling units, using I/Os to trigger simple things like solenoid valves. I imagine this may take some unravelling of the controller.


    I can not get motor power on - so I'm unsure of the status of the bots. They appear to have been well taken care of (clean, labelled, no visible damage), so i am hopeful they had light usage at the school for training purposes.


    This is my first experience with Kawasaki robots (Kuka and Fanuc I have experience with). Any assistance/advice would be most appreciated. I have attached photos of the inside of the cabinet - some notes on the door and pendant. Is there an integration manual?


    Not sure why I can only upload a single attachment so I zipped them - thanks and apologies for newb mistakes :)



    Robot 1 2
    Model ZZX200S B ZZX200S B
    Serial Number ZZX201614 ZZX202219
    Number of Axes 7 6
    Mfd. In Apr-07 Mar-08
    Controller D+ D+
    Model D32 G A001 D32 F D001
    Robot ZZX200S B ZZX200S B
    Serial Number ZX201614 ZZX202219
    Mfd. In Apr-07 Mar-08
    Dwg No 91004-1168 91004-1168
  • AD
  • Welcome to the forum...... :beerchug:

    I would consider making some request to KRI Kawasaki Robotics Incorporated regarding these as if the firmware is required, then they would be your best source and also for any specific manuals.


    Any 'valuable' information has been lost, especially the servo gun and external axis information due to the hardware initialization and so your controllers are now empty of ALL information and will have to be manually setup again.

    The backups are incomplete and useless.

    The only hope you have is that none of the boards are faulty now.


    My goal is to use them as basic material handling units, using I/Os to trigger simple things like solenoid valves. I imagine this may take some unravelling of the controller.

    Absolutely............it all depends on just how far you are willing to go with stripping things out.


    Saying that, there are some areas you could do with addressing, clarifying first.


    1. Check out the attached external IO manual, referencing X7, X8 and possibly X9 on 1KP board.

    You may need to remove the external connections to X7 and X8 and temporarily install the default jumpers in order to complete the necessary safety circuits in order to move the robots.


    2. Alternatively, what connectors are available on the controller, can you provide images of the outside of the controller (sides and the rear) as I suspect these were originally made to be part of a cell which is controlled by a line controller.


    3. Have you got ANY data sheets for the robots (5-6 sheets of paper with information which are usually attached inside the controllers).


    4. Do the arms have a 'black box' fitted to the rear of JT3 arm?.


    5. You have 1FS and 1JR board fitted which you may not need.

    - 1FS is control net comms and 1JR is a relay board (from memory).


    6. You maybe better sourcing a 1GW board (32 input and 32 output board) to replace the 1JR board.


    7. The errors are due to the hardware initialization you carried out as this has cleared the controller of ALL default information.

    - Robot model requires setting in order to remove the servo errors.

    - Relay board option requires enabling in order to remove the No. 1 I/O board error.

    - If you can answer 4., a simple loading of a file or manual setting of the robot model could be used.

    - This would at least make the controller error free.

  • If you have a 'black box' fitted to the rear of JT3, then this is likely to include what is called an Arm id board.

    This board not only contains the robot model, but should hold the last zeroing information of the arm itself.

    Assuming this was in use before you hardware initialized it, should be able to be used again.

    When carrying out a hardware init, the Arm id is turned off, so you can either:

    - Use ZROBOT command in the teach pendant keyboard and manually enter the robot model and then re-zero it.

    - Use a file to enable the Arm id board and then use the board to set the model and zero the robot.


    However, please note that one of your backups was incomplete (and likely hung during the file save), which could mean the memory is not too good on the 1RA board.


    Personally, I would initially use ZROBOT to at least get the robot into a movable state before doing anything else, then you could re-zero and initially test it before anything else.

  • Thanks so much for the break down!


    I have not powered up the second bot - perhaps it will boot without reinitializing - I will wire it up and give it a shot this weekend.


    Absolutely............it all depends on just how far you are willing to go with stripping things out.

    I'm happy to strip anything out - simpler the better in my mind! A robot I can offline program and call 24V I/Os is all I really want.

    2. Alternatively, what connectors are available on the controller, can you provide images of the outside of the controller (sides and the rear) as I suspect these were originally made to be part of a cell which is controlled by a line controller.

    3. Have you got ANY data sheets for the robots (5-6 sheets of paper with information which are usually attached inside the controllers).

    Cabinet photos attached - let me know if you need any close ups. Unfortunately I don't have any documentation - empty inside the cabinets ||

    4. Do the arms have a 'black box' fitted to the rear of JT3 arm?.

    I took photos of the JT3 - there does appear to be an external black box - rectangular in shape. I added arrows pointing where I believe it is.


    I'll read up on the IO manual and boards you mentioned. Thoughts on sourcing boards?


    Thanks again for the help kwakisaki

  • However, please note that one of your backups was incomplete (and likely hung during the file save), which could mean the memory is not too good on the 1RA board.

    Hmmm I don't believe I ever got a confirmed download when running SAVE/ ALLDATA - I let it run for 10 minutes or so - did I end the process prematurely?


    I ran ZROBOT - read out below:

    It got me further than I had been - attached is a photo of the pendant upon rebooting after ZROBOT command, clearing errors and zeroing. Somehow arm data was lost? Or am I misunderstanding what ZROBOT command does?


    External hold and e-stop probably related to the IO you mentioned above? Safety jumpers on my Kuka are pretty straight forward with the schematic - something similar here? (Knowing that is a messy question for many reasons...).


    Progress! Thanks again.

  • Thanks for the additional images, that helps a little.

    When posting, so that I can keep up with what your doing, if you have done anything in addition, can you state what you have done.


    Looks like you have some customized interfacing so we need to ascertain just what/where these connections are interfaced with:

    - Left side of controller looks like the interface to the weld controller - kindly it's got a legend on it.

    - Would be interested to see where these go - suspect the 1JR board.

    - Top of controller - Not too sure about that, could be the field PSU, CNET and Safety Chain - Is there any writing on or can you trace the wires back (I suspect some of these may go back to 1KP X7/X8/X9).

    - The front black panel on the controller looks customised too, can you trace those wires, I suspect they interface with the 1JR board.


    ANY file save should always display a 'file save completed' message.

    - RS232 file save will take ages, baud rate is usually 9600, but could be set at 38400, but still slow.

    - Depending on amount of data, and how you save depends on how long it takes.....could take 30mins.

    - I can see you have RS232 connectivity by the screenshot, so that's a good start for now.

    - As you have RS232 connectivity, I can send you some files to load in.


    So I would proceed with the following:


    1. Current Controller:

    - RAM battery installed on 1RA board needs replacing ASAP (single cell at the front of board).

    - If you have replaced this already, check installed correctly/correct cell and leave powered for 1hr and re-check error is cleared and after power cycle.

    - IO board, Joint abnormality errors should be resettable.

    - Check sum error is normal after initialization, cannot be resolved until arm data error resolved.


    Questions for current controller:

    - I notice the joint angles are all at 0.000...have you done ANY re-zeroing, if so, please describe in full?

    - Worried about arm data load error.

    - Are you sure the selected Arm in ZROBOT matches the data plate on the robot?

    - Can you provide image of Aux function 0804 (both pages)?

    - Can you take images of the dip switches on front of 1RB board (you can access these from the front)?


    Try the following to rectify arm load data error.

    - Check your conversation out, load in the file I sent you.

    - To load, place in the root directory of KRTerm and at command prompt type LOAD DARMID.txt

    - Reboot controller, you should now see immediately a message to load settings from robot or controller, choose robot and see if after resetting errors, you just have check sum error displayed.


    2. Other Controller:

    - Just power it up, ignore any errors and attempt a file save via RS232 and give it a good 40 mins.

    - You don't need to connect the arm umbilical's for this, just the power.

    - Then post it......just rename extension from .as to .txt (forum allows just .txt)


    Attached are some manuals for you:

    - Troubleshooting.

    - Arm ID board manual.

    - Standard Operations Manual.

  • Hi kwakisaki


    LOAD DARMID.txt ran and successfully loaded.

    Rebooted

    Read out below upon rebooting.



    General:

    Tried to Save AllData to PCMCIA 32mb board - let run for hours - hangs up at AUX settings and gave me a few CPU ERRORs (PIC#6) PC=A42B8867, 69B811A0, 7BD200A8


    Installed X7 jumpers and now holds are gone ( PIC#2 when deadman is depressed)


    Top of cabinet config (PIC#5) - wires traced and they go to switches on cabinet door and then to X7/X8/X9 on 1KP board. (Pic#7). 1JR board goes to PLC looking board at base of cabinet door.


    1. Current Controller:


    -Batteries installed and controller left on for an hour - getting battery error still - I have additional, I will try alternate. No additional coin batteries anywhere? I have had to dig in Kuka controller for troublesome battery before.


    -When I got encoder error I manually set all joint angles to '0' to see if I could clear error. Joint positions now set from arm ID board (see code above).

    -Pretty sure I set it right - ZX then 200S-B001 (controller has ZZX200S B) did I make a bad assumption?

    - AUX pages attached (PIC#3-4)

    - 1RB dip switches shown in PIC#1 - looks like D2029 error points to 7th axis error and S8 switches?


    Can't get past motor code mismatch error - motor power won't turn on. Thoughts? Hesitant to mess with 1RB switches before reading more.


    2. Other Controller:

    I only have one plug.... working on that haha. Once wired I'll attempt alldata save without reinitializing.


    Thanks and happy Saturday!



    Edited once, last by colemajr ().

  • Some progress then.

    Thanks for the additional pictures and screens, helps out immensely to see where you are at... :top:


    Just to fill in some blanks...... now you've enabled arm id board.

    If you re-initialize again without a backup available to load, then arm id board will be disabled again.

    Now upon each bootup, the controller will communicate with the arm id board and also, should you have an extended arm id io board fitted inside too, you will have access to local arm io all located in the black box (rear of JT3).

    This confirms the arm id board is functioning now and can be used.


    The arm id board (with you selecting robot side) has now updated the robot model and zeroing information from robot to controller - now they match.


    So to first reference your boot up screen and errors:


    1. RAM battery error worries me, you said you replaced this, can you confirm this is correct battery and connected correctly - located on 1RA board.


    2. Only 2 sets of batteries exists in Kawasaki D/D+ controller.

    - RAM battery housed on 1KA/1RA board - single cell.

    - Encoder battery housed behind rear panel of robot where umbilical's connect - dual cell.


    3. No. 1 I/O board not installed error - Not worried about that, as you have initialized, the total IO will be set to 32 input and 32 outputs, so it is looking for a 1GW/1HW input/output board, as this is not installed, the error is expected and can be cleared (will re-appear after a power cycle).


    4. JT7 error references, not to concerned with this either, as characteristics of the an external axis will have been wiped due to initialization, so even though robot model is now set for 7 axis, hardware should be set for 7th axis, but in software the ext axis settings will not be set.


    5. Your reference to 1RB dip switches is definitely correct.

    - We will tackle this based on answer to 9.


    6. Check sum error, totally standard when wiping controller information, as all previous information is no longer there, so data check sum has changed.


    7. Saving to PCMCIA card hang up (could be PCMCIA card itself).

    - What happens if you try and save using the RS232 connection you have.

    - Do you still get the same outcome with hanging.

    - Usual when file save is complete, to see message 'file save complete'.

    - If you still have hang up, I suspect 1RA memory blocks may be bad.

    - A procedure is required to flush memory to test if bad blocks.


    8. With adding jumpers to X7 and X8, ALL external safety signals the controller is looking for via other routes have been removed.

    Therefore the robot has now the potential to move.


    9. OK so you have choice to make:

    1. Make current robot with all 7 axis - will take time, as you need 7th axis parameters.

    2. Make current robot to 6 axis (I recommend this, as it will be quicker to get moving/tested).


    As the controller has been 'cleaned' out, our mission here is to simply make the minimum changes/settings to establish robot motion, so let's walk before running....

  • So what I would be doing now to the 1st controller.

    - ref the hang up and battery error, ignore for now.


    1. Carry out a ZROBOT again and just change to 6 axis.

    2. Turn off controller.

    3. Locate S8 on 1RB board (Top one - you see dipswitch 4 is ON, turn OFF so all S8 are OFF).

    4. Power controller on.

    5. Arm id board should ask question again, this time select controller side.

    6. After bootup what errors are being displayed - post screen again like you did before.

  • Ok - wired up the second robot and controller.


    SAVE ALLDATA was successful and it did not require initialization. No dipswitches have been modified from current original state. Alldata back up attached below.


    To attempt to test robot movement I have jumpered X7 on 1KP board.


    I am still seeing an external hold I am debugging but I am able to get motor power on. See screenshots attached.

  • Cheers for those.

    These look more and more like ex automotive the more I look at them.


    Firstly you cannot swap certain boards between controllers:

    - The 1st is a D+ controller with 1RA and 1RB - Yellow tabs.

    - The 2nd is D controller with 1KA and 1KB - Red tabs.

    Yellow and red tabs cannot be mixed.


    Secondly, the controller is booting up and executing some PC Tasks (background programs, including S-LOGIC).


    Thirdly the controller needs re-zeroing - I assume you had encoder battery error.


    But for now, yes I see the jumpers you have inserted on X7, but I what I could do with you doing as well is:

    - On X8 make a note of wires and remove them all then jumper out 1-2, 3-4, 5-6, 7-8.

    - X9 leave as is at the moment.


    Goto the front panel and switch the hold/run into run and the panel below the run hold switch to run and post the teach pendant screen shot please?

  • I switched both switches on front of panel to Run and......


    ITS ALIVE! Not quite a hello world but just as exciting.


    No modifications done to X8 yet. I suspect re zeroing needs to happen - only able to jog in one direction currently.

  • OK, great news, leave X8 alone for now.......strange as the external trigger is wired in, unless one of the safety relays on the front panel is shorting this.....never mind for now.


    If you have motion in one direction, you can see from the joint angles, they are ridiculous values and lie outside of the software limits - that's why you can only jog in one direction.

    Just by powering the servo's and brake release occurring without errors......is good..... :bravo:


    In order to re-zero it, you will need to get the robot into a 'right angle' posture.

    However - is the robot fixed so that it cannot tip over, if it is not, then zeroing will be impossible until robot is secured so that it cannot topple?

  • Not mounted - so i made very subtle movements! Hmmmmm now i can't get it back to shipping position - can I manually set values lower so opposite direction becomes available again?


    Thanks for all the help! super exciting and happy i went to the trouble of rescuing them. (or one of them at least haha)

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now