How to install older version of FRVRC for use in RoboGuide

  • When trying to open the BACKDATE.DT file it says I need to have FRVRC 8.3.

    Through FANUC's portal I am able to download RCS v8.3, however, it comes with a README with the following in it: "Do not install a ROBOGUIDE product and an RCS Module product on the same computer. RCS modules are standalone controllers for use with products like Delmia and are not compatible with ROBOGUIDE. To install a new controller in ROBOGUIDE download the entire package and run the setup.exe included with ROBOGUIDE."


    Now I'm left with the question, if I have to re-setup my RoboGuide in order to get access to the older FRVRC's, will this setup delete all my previous workcells and associated data? or will it overwrite roboguide setup/config files and leave my working data alone?

    Edited 2 times, last by aacosta13 ().

  • Place your Ad here!
  • In my experience, your older work cells will be fine.


    The first time you open them, they will automatically reload themselves and go through a controlled start. This will take a few minutes at most. After the first load, they will then open as they always had before.

  • Thank you for the feedback PDL. In your experience, will the license be affected if I set up roboguide again in order to install the missing FRVRC's? This has become my new concern. I have contacted FANUC as well, still waiting for a reply via email

    • Helpful

    No, but I have a universal subscription, so your mileage may vary.


    All I ever do when installing a new version is just to run the installer as administrator. I don't uninstall any previous versions, the installer will just add on to what I already have. It's actually very simple.


    With v.9 now at Rev Y, I have done it a lot! It's always been the same experience going back to the earliest days of v.7 for me.


    When upgrading computers, I do use the license manager transfer function. It's very simple and works well.

  • You need to re-install roboguide and while doing that check the version of FRVRC that you need. You dont have to uninstall the current version, just run the setup again (as admin) and make sure you have checked the necessary version of FRVRC. You may also need to install some other software pieces, installation wizard will give you those pop ups if needed.

  • How do you know which version of FRVRC matches your robot? my robot is 16-iB/R-3jC V7.20/12 P, so do i need FRVRC720 or doesn't it work like that?

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners