Motosim "Controller <--> Pendant Connection Failure"

  • Hi all,

    This morning I tried to open in Motosim one of my working cells and has been welcomed with below screen:

    Unfortunately, it happened to every cell I tried to open, even with new ones just after insert a controller.


    My Motosim version if that helps:

    0000,MotoSimEG-VRC ver 2021


    [FILE VERSION]


    *** MOTOSIM EG-VRC ***


    --- SYSTEM ---

    ./Archiver.exe 1.20

    ./CollisionDetectorManager.dll 12.00

    ./COMGraph.dll 1.70

    ./CSAPP_IF.dll 1.70

    ./JobBrowser.dll 1.70

    ./Hslsrv32.exe 4.00

    ./ModelMakerCLI.dll 12.00

    ./Liner32.dll 1.10

    ./MotoCom32.dll 4.40

    ./Motolk.dll 5.45.00

    ./MotoLkr.dll 7.1.0.10

    ./MotoSimEG-VRC.exe 12.00

    ./msegcom.dll 12.00

    ./PathPlanEgn.dll 12.00

    ./RobotModel.dll 2.00

    ./RtsLib32.dll 12.00

    ./RtsRRSx.dll 12.00

    ./Rwdll32b.dll 12.00

    ./SpaCDHOOPS_3DF.dll 12.00

    ./SPACDKernel.dll 12.00

    ./SweepModelGenerator.dll 12.00

    ./VRC_IF.dll 4.80

    ./VRC_IF_CS.dll 1.40

    ./vrp32.dll 4.40


    Does any body know what could trigger such a problem? I tried online and offline with LAN adapters on and off, etc. no change. Still the same message.

  • Place your Ad here!
  • Have you tried to reboot the controller from within MotoSim?


    Did Windows update occur recently?

    I know a thing or two, because I’ve seen a thing or two. Don't even ask about a third thing. I won't know it.

  • Can you send your CMOS.bin, i can check in my Motosim software too.

    I don't think it is related to CMOS, as I can't open any of my existing cells.


    Last time, when I had this type of message, it was triggered by wrong settings CV-X Keyence camera. I followed the manual and there was a wrong value to type to the controller. This cause a LAN port to crash the whole system and reboot TP. But it was completely different scenario.

  • When you've installed the motosim there was a file "motosim egvrc delete".

    Close the motosim, execute the file and open the motosim again

    Thank you for suggestiion.


    Solution: Run installation and choose the Repair option on the screen, were you are asked for choosing the type of installation you want.

  • I had that problem, it was all related to the firewall settings. The reinstall may have fixed the setting to allow through the firewall.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners