Command gear torque A1 - differences between master/slave motors

  • Hi,

    Robot TITAN 1000H, KRC4, KSS 8.3


    I have problem with frequent occurence errors:


    KSS01073 - Command gear torque A1

    KSS26010 - Ackn. Current overload after 60 s (A1.S1)


    The A1 axis differences during movement (even without A1 movement) oscillates between master / slave 0.4 - 40 DEG



    Load data correct - calculate with Load Data Determination


    What could be the reason?


    Regards.

  • AD
  • Sorry for the delay.


    1. The robot is tilted 30 degrees forward.


    2. No matter what the motion type, but it happens if A1 tends to + -90 degrees, around A1 = 0 it is not, it also happens in T1.


    3. When I "turn off" the tilt in $ROBROOT, the difference between SLAVE/MASTER is much smaller and I only have errors:



    KSS26010 - Ackn. Current overload after 60 s (A1.S1) - if A1 is positive


    KSS26010 - Ackn. Current overload after 60 s (A1.M) - if A1 is negative

  • Well actually you can tilt it like this but this requires setting $ROBROOT and maybe $ERSYSROOT correct. So its needs to be configured correct in machine data. KRC is aware of gravity direction. Only exception I know of you should not tilt the robot would be absolute accuracy, Absolute accuracy is very sensitive with regard to different tilt than in creation of the absolute accuracy correction files.


    Fubini

  • Do you think can I try to cheat it somehow? Additional tuning?


    Fubini If I had $ROBROOT set correctly (with tilt), i got error:

    KSS01073 - Command gear torque A1


    without tilting in $ROBROOT only:

    KSS26010 - Ackn. Current overload after 60 s (A1.S1/M)

  • I had the tool selected with the calculated load_data. I did not check the $LOAD variable. But I think the load data was correct, because without that overload and the jerks were so big that there were always errors on different axes. The mounted tool weighs over 300 kg.

  • Do you think it should work?


    I will check the load data again. Maybe I made a mistake somewhere. Or maybe a configuration error.


    Kuka says the robots cannot be tilted. If they are not intended to do so.


    Has someone tilted the KR 480 robot? I am considering a robot replacement.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now