KUKA motor losing its zero.

  • Hi guys,

    I have been using ME_16_60_42 motors, used a linear drive. I have taught it zero position, and after I run it for rounds back and forth as test and check it’s zero position, they will be no more there. Amazingly it loses the zero position, I again tried the same process teach it a zero position and did test with back and forth motion. And again it loses the zero position.

    So, what are the possible reason for losing zero. Can it be mechanical problem or can it be because of ASYPTP motion command or can it be because of machine data, what can it be?

  • AD
  • "Loses zero position". Does this mean that the robot throws a Mastering error? Or simply that the zero position of the axis is not mechanically repeatable?


    If the latter, the most likely culprit is mechanical slippage between the motor drive shaft and the linear axis it is driving.

  • SkyeFire, yeah i have a big doubt about the mechanical slippage. have to check it. And actually there is no matering error , it is shifting the zero position somewhere else.


    panic mode but how to find the right gear ratio/ transmission ratio for linear drive system.

    BTW i have not used the gear box too. it is straight connected to the shaft.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now