I need config for abb irb 6400/f/2.4-150e s4

  • I need help.


    I bought a robot.

    Man order: 099618

    Ref.No R6411380009

    Serial No 6400-4988


    ELMO drives are installed on all axes, for example 5 axes

    Type: PS 130/6-50-P-PMB-3739

    Art.No. 3 HAB 4042-1/5

    Serial No. 605.5890540


    DSQC223 2pcs

    DSQC315

    DSQC256A

    DSQC335 is robot computer 4911014 SDG D63L and SBV D62H

    DSQC325 is the main computer

    DSQC317 is 6MB

    DSQC314B is DC-LINK

    DSQC236 drive boards with different letters

    I have disk:

    Program no 3HAB2319-1/08 IRB 6400 Elmo/Siemens 2.0

    Program no 3HAB2319-3/05 IRB 6400 M96 2.0

    Program no 3HAB2342-1/04 IRB 6400 2.1

    Program no 3HAB2340-1/04 IRB 6400 Elmo/Siemens 2.1


    I can not find the correct configuration with the dс-link I need DSQC314B.

    does anyone have the disk i need?

  • First > welcome to the forum and I'm very impressed by your level of detail.


    It depends on the version of software:

    If you are using 2.0 RobotWare for the M94A with Elmo motors, then use the 3HAB2319-1 IRB6400 disks

    If you are using 2.1 BaseWare, then use the 3HAB2340-1 IRB6400 disks


    Loading any IRB6400 disk automatically selects the larger DSQC314B DC-link required for the IRB6400.

    Be aware that the encoded serial # on the IRB disks needs to match the serial number of the core software set loaded in the controller or it will error.


    Is there a specific problem where it is not automatically loading the correct DC-Link?

  • wowa_wa

    Changed the title of the thread from “I need config for abb irb 6400/f/2.8-150e s4” to “I need config for abb irb 6400/f/2.4-150e s4”.
  • I have already collected many different discs. On the Internet and in the support of abb.

    Found this table.


    What is the difference between the software, I don’t know which one is better to install.
    There are disks:
    3HAB2316-1/13 Basic 2.0 installation failure
    3HAB2317-1/08 Basic CommWare 2.0 installed normally
    3HAB2333-1/07 BaseWare OS 2.1 installed normally
    3HAB2333-1/08 BaseWare OS 2.1 installation failure


    On disk 3HAB2319-3/05 all drivers with dc_link" -type "DSQC_249B"

    On disk 3HAB2342-1/04 all drivers with dc_link" -type "DSQC_249B"

    On disk 3HAB2340-1/04 and 3HAB2319-1/05 and 3HAB2319-1/08 there is a driver for dc_link" -type "DSQC_314C"

    M642275I.CFG

    Code
    #IRB6400PE_225_75
    echo -text "Installing IRB 6400PE/2.25-75 Elmo"
    install -resource Function -name "IRB" -descr "6400PE/2.25-75 Elmo"
    config -filename  flp1:/irbcfg/m642275s.cfg -domain MOC -internal
    config -filename  flp1:/irbcfg/m642275i.cfg -domain MOC -internal
    config -filename  flp1:/irbcfg/m642275e.cfg -domain MOC
    goto -label NEXT_STEP 

    and S642275I.CFG

    Code
    #IRBS6400PE_225_75
    echo -text "Installing IRB 6400PE/2.25-75 Siemens"
    install -resource Function -name "IRB" -descr "6400PE/2.25-75 Siemens"
    config -filename  flp1:/irbcfg/s642275s.cfg -domain MOC -internal
    config -filename  flp1:/irbcfg/s642275i.cfg -domain MOC -internal
    config -filename  flp1:/irbcfg/s642275e.cfg -domain MOC
    goto -label NEXT_STEP
    #NEXT_STEP 

    But the configuration is for a different type of robot, if I choose it, then I have errors
    50142 Manipulator config error
    10014 System failure state
    10002 Program reset


    If you select 2.4-120 then I get one of the errors
    33107 Incorect Dc-Link type

    Does anyone have the correct drivers?

    There is an idea to change in the file, but I think it will not work, since there are 3 configuration files, and I can only change in 2


    What should be selected on the question when installing a standard or a service?

  • DC-Link 249B and DSQC314B are normally compatible with the same Typcode.

    Check, is really installed a Type-B version.


    What should be selected on the question when installing a standard or a service?

    Service is normally only when you have external axis.


    What is the difference between the software, I don’t know which one is better to install.
    There are disks:

    In your case, I would choose:

    3HAB2333-1/07 BaseWare OS 2.1 installed normally

    Version 8 from Robware 2.1 needs normally other PROMS.

    IRB-Disk:

    3HAB2340-1_04 Elmo-Siemens 2.1

    Choose:



    Choose ELMO:


    correct file installed should be:


    #IRB6400_24_150

    echo -text "Installing IRB 6400/2.4-150 Elmo"

    install -resource Function -name "IRB" -descr "6400/2.4-150 Elmo"

    config -filename flp1:/irbcfg/m642415s.cfg -domain MOC -internal

    config -filename flp1:/irbcfg/m642415i.cfg -domain MOC -internal

    config -filename flp1:/irbcfg/m642415e.cfg -domain MOC

  • DC-Link 249B and DSQC314B are normally compatible with the same Typcode.

    Check, is really installed a Type-B version.

    Yes, there is really installed a Dc-Link DSQC314B board 3HAB2216-1


    Correctly I understand that you suggest me to set the BSW 2.1 M96 configuration as in the picture.


    Maybe you have a wiring diagram and technical, manual documentation for the operator panel M10C7133232TWFWX131?

    There are installed programs S4 Tophat, Robcomm Dispatcher and others.Searched for config files on the panel but didn't find.

  • Установка проходит хорошо.

    3HAB2333-1/07 ОС BaseWare 2.1

    3HAB2356-1/03 Обучение подвесному тексту 2.1

    3HAB2340-1/04 Установка IRB 6400/2.4-150 Elmo

    3HAB2344-1/00 Расширенные функции 2.1

    После установки контроллер не используется. Просто посетите


    При установке неверный id на первом диске.

    3HAB2317-1/13 Базовая версия CommWare 2.0


    А на диске 3HAB2333-1/07 BaseWare OS 2.1 установлена нормально.

  • 3HAB2333-1/07 ОС BaseWare 2.1

    3HAB2356-1/03 Обучение подвесному тексту 2.1

    3HAB2340-1/04 Установка IRB 6400/2.4-150 Elmo

    3HAB2344-1/00 Расширенные функции 2.1

    Yes. This is a disk set for BaseWare 2.1 M94A (Elmo) IRB6400/2.4-150

  • Spitballing here:


    Try only:

    3HAB2317-1/13

    3HAB2331-1/00

    3HAB2319-1/08


    Perhaps contact with ABB is order to ensure the PROMS being used are correct.


    It looks like someone was kind enough to send you ABB WebConfig info about your system. The mention of S4 TopHat indicates this was a GM robot at some point.

  • -SBV & -SDG EPROMs will work for versions 2.0, 2.1, 3.0

    Are you loading Stand(ard)?

    It passes the cold-start hardware tests?

    On problem units, I would pull all 3 computer boards for 2 minutes (careful of the brittle plastic) and try again.

    Perhaps time for 'PC as a service tool' and see where it's hanging up.

  • Installed disks:

    3HAB2333-1/07 BaseWare OS 2.1

    3HAB2356-1/03 Teach Pendant Text 2.1

    3HAB2340-1/04 IRB 6400 Elmo/Siemens 2.1

    As you can see, it doesn't load.

    after power off

    Edited 2 times, last by wowa_wa ().

  • Over the years I learned, I am not certain of the reliability of my learning :thinking_face: , that when errors were encountered.


    SYS HALT ERROR - from servots.c,1346
    SYS STOP ERROR - from ipolts.c,2792


    there was a problem with the measuring system. I recall that the sys halt stuff was a problem in the axis computer, cabling, or SM Board.


    Also, this text


    94-01-01 10:03:22 type = ERROR id = HARDWARE code = 8001
    arg 0: 1.000000 arg 1: 0.000000 arg 2: 0.000000 arg 3: 0.000000 SYS FAIL - from c25.c,1326

    indicates a hardware fail. (Good old 8001 code, in S3s that was REALLY bad)


    Perhaps SKOOTER or LEMSTER will weigh in.

    Edited once, last by SomeTekk ().

  • Photo boards.

    I'll pull out the board tomorrow and look at the markings on it.


    If I install these disks, the controller starts up as M96. And an error on the wrong DC-Link

    3HAB2333-1/07 BaseWare OS 2.1

    3HAB2356-1/03 Teach Pendant Text 2.1

    3HAB2342-1/04 IRB 6400 2.1

    3HAB2344-1/00 Advanced Functions 2.1

    Difference in the last two discs

    Edited once, last by wowa_wa ().

  • I got all the boards today and looked, all nameplates correspond to the names.
    I tried to install a configuration that used to run with errors, now also errors.

    Where can I look for a problem?

  • Tried installing BaseWare 2.0.

    Installed, loaded, working now I do not understand anything. I'll try to see what he writes through the comport.

    Can someone give robotstudio 3.0 and config 2.0 for this system to fix it?

  • SJX: I saw DSQC306 too and thought that might be it but it also said 25MHz. The 306 is a 20MHz so I was going to ask to verify the boards. We got with post #14.


    SomeTekk: I remember software loading issues somewhere when the SMB communication is missing during load but not sure if this configuration though.


    wowa_wa: I remember not being able to load RW 2.1 but could load CommWare 2.0. It also passed the hardware tests. Ended up being a bad Main CPU. Like your problem, it was hard to find. The picture in post #14 shows the Main CPU is the DSQC325, which is compatible.

  • So I tried to install from floppy disks, install system 2.1 and it works

    Boot info from comport from main board

    Boot info from comport from dsqc325 board

    And with the floppy disk emulator, it does not start after installation.

    Or such glitches or all the same, the pattern of installation from disks

    Who has a table of disks for proms 4911014-SDG D63L and 4911014-SBV D62H?

    Can only 2.0 system be installed on them?

  • -SDG & -SBV EPROMs will work with 2.0, 2.1 & 3.0. They are very stable and the last S4 revision except when ABB came out with a 3HACxxxx set in the very late 90's with a few changes related to the Y2K hysteria.

  • I burned all the disks to the floppy and installed.

    3HAB2333-1/07 BaseWare OS 2.1

    3HAB2356-1/03 Teach Pendant Text 2.1

    3HAB2340-1/04 IRB 6400 Elmo/Simens

    3HAB2344-1/00 Advanced Functions 2.1

    The installation was successful and the controller started up.

    After installation same problem with dc-link.

Advertising from our partners