Connecting Kepware to Roboguide robot

  • I am new to kepware and SNPX, I am trying to connect my local (trial) server to my roboguide robot. From what I have been able to gather on the internet and these forums, the correct IP is When I open the browser and connect I can connect to to see my robot info.

    When I configure my kepware channel, I am using GE Ethernet and creating the robot as a GE Open connection using the IP and port 9000. I am unable to see any of my connections when I open the quick client though, and I am not sure what I am doing wrong on Kepware.

    Any help would be appreciated.


  • What software version is the Roboguide controller using? Is the HMI SNPX option loaded on the virtual controller?

    I have connected Kepware to real robots(it may be different for Roboguide). With software versions older than V9, I used SNPX and GE Open connection. For version 9 robots I used an OPCUA connection in Kepware.

  • Im using roboguide controller 8.3, yes it has SNPX but I am not getting any communication from the robot as far as I can tell.

    I set the port to 9000 in kepware, I don't know if that matters or not.

    I appreciate the help, what were your driver settings when you set it up in Kepware? I am using the GE Open, maybe I am communicating in quick client but it doesn't look it to me.

  • Hmm I have the same settings, pinged my local address to make sure it was correct.... in roboguide did you have to set up the external device OPC and connect it to Kepware? I have a tag set up to read DI100 but it keeps failing to connect

    EDIT: I was able to connect, I restarted my computer and ran Kepware as administrator, seemed to do the trick.... thank you for your help

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now