W1000 and E1123 Faults on external axis JT7

  • Hello,

    I'm trying to setup two external axes on the F60 controller: 7th axis is a 3D printed "weld gun" that has a 75W motor attached to a small rack and pinion that will be controlling the gun arm (image attached), and the 8th axis is a linear rail. I'm setting both up as a Linear Axis in the Axis Type parameter, and the linear rail one is working fine, however the 7th axis is throwing three particular errors:

    • W1000 - Cannot move along straight line JT7 in this configuration
    • E1123 - Speed Error JT7
    • sometimes E1556 - Final command value for JT7 suddenly changed

    This 7th external axis is not set to have any coop mode and the faults are occurring in manual/ teach mode in Joint motion. Every other joint I can move without issue. Situations when the faults occur:

    1. When I try to jog JT7 in teach mode (at any speed it throws either the W1000 or E1123 fault)
      1. I tried to move other robot joints out of the way in case of singularity, but I don't understand how it knows if the external axis is going to interfere with the robot joints when I don't have the external axes set up in coop mode. In which case, not sure what this motor is detecting singularity from.
    2. When I turn the motor on and have the deadman switch pressed, JT7 will not throw a fault, but if I try to physically move the pinion even a bit by hand (to see how much it may "fight" me) it will fault out to E1123 immediately without much force being applied.
      1. This makes me think that it might be gains, but I tried changing the servo parameters and it doesn't seem to have any much effect
      2. Perhaps current/ torque/ speed limit error? In which case I would like help identifying the associated parameters for these
      3. Encoder following errors?

    I've been following the External Axis Addition Manual for this, but not sure if there are any other parameters/ settings that I missed in the normal operation manual that may be affecting this issue. I'm hoping that this is not a hardware problem (encoder for ex.)

    Any help is appreciated, thanks!

  • AD
  • - What motors and encoders are being used and have you loaded the applicable mot files provided by Kawasaki required for the specific external motor and amp configurations?

    - Are the relevant parameters correctly set.

    - Have you tried setting as a rotary axis instead and then adjusting the equivalent radius value.

    - Have you 'simple tuned' the external axis or just left at defaults.

    - What have Kawasaki advised and supplied regarding this setup.

  • Updates:

    • Already tried simple tuning, switched to rotary axis, and set the parameters to the best of my knowledge for the external axes parameter pages. In turns out...
    • ...that it looks like I was missing the servo parameter/ motor file that was supposed to be provided by Kawasaki. I thought that as long as I chose the motor that I'm using as part of the parameter setup, once I save the settings, it will set the correct values according to that motor for me. Looks like the parameters never took until an upload of that .mod file.

    Should be good for now, thank you :)

  • That's good to know.......... :top:

    Most cases, you would order the system with the external axis already installed and also the mot file applicable to the combination of amp/motor being used.

    However in cases where clients order and configure it themselves just by the manual alone, can miss out some fundamental configuration details.

    Mot files are critical with any additional axis (they are mod files, but for some reason call them mot).

    If you go on any training provided by Kawasaki, these are always included as part of the procedures for adding an external axis and usually demonstrate the differences when external axis has been added without the use of mot files too.

    What sometimes happens, is I think similar to your case.

    You install everything and carry out some preliminary tests and all appears good.

    It's not until you start 'applying load' to the external axis in real time, do you find these errors appear.

    Good to hear your progressing..... :top:

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now