KRC4 Compact and Omron NX1P2 Ethernet IP Communication

  • Hi everyone,

    I try to make communication between OMRON NX1P2 PLC and KUKA KRC4 Compact through Ethernet/IP. I did make every adjustment I know but it is not connected. I cannot IO Mapping because that the connect button is inactive for connecting Ethernet IP. Also, when I try to connect from the menu instead of the IO Mapping page, I get a warning in the images.The images about this issue are attached and the information about the installation is below. Is there anyone who can help me?


    KSS 8.6.7

    KS V8.6.353

    I am using KLI interface virtual5 and Workvisual 6.0.

  • AD
  • what are the network settings of both KRC and PLC?

    what is the IO mapping on the KRC side?

    what is the EDS you are using?

    Network settings of KRC:

    IP Address: 192.168.150.2

    Subnet mask: 255.255.0.0


    Network settings of KRC:

    IP Address: 192.168.150.3

    Subnet mask: 255.255.0.0


    I cannot change anything about IO mapping because that the connect button below is not active.


    I use KRC4ScannerAdapter_8_3.eds file from Wov files.

  • your network settings are not proper but will work. (for that address range subnet mask should be 255.255.255.0)


    without mapping, there is nothing for fieldbus driver to transfer so it does not even try to run. you MUST perform IO mapping.

    notice how in upper right side you highlighted "EthernetIP" (under Fieldbusses)?

    notice how you did not select anything on the Robot IO (under KR C I/Os)?

    once you select robot I/O (for example Inputs) you can start mapping.

    then you select Outputs and continue mapping...


    read labels at the very bottom of the screenshot. under fieldbus you selected 1 byte of inputs. the bottom label says you selected 8 bit(s) in 1 signals. this means Map button will not be enabled until you select also 8 bits on the RobotIO side.



    Lastly size of I/O blocks need to match. you selected huge 256 bytes as input and output block size. you probably do not even realize how much that is...


    256byte * 8bits/byte = 4096 bits


    and 4096 bits is entire address space of the robot. it means there is no I/O left. all robot I/Os are used just to communicate with one node (PLC).


    if that is the case, you may want to extend the robot IO address space. you can double it.



    btw,

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • Firstly thanks for your answer panic.

    I arranged the subnet mask as you said (255.255.255.0) and I performed IO Mapping. Again as you said, I made the size of inputs and outputs to 5 for PLC and Robot. But I have still the same problem. In PLC Software, it seems that the connection does not exist. Is there any different suggestion?

    that statement is incomplete. you use it where?


    you should be using it in your PLC software (master need to be aware and in control all of its slaves)

    I use it for PLC Software. I upload the .eds file to PLC Software and I choose KR C4 on the Ethernet IP page.


    Thanks in advance.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now