Remote Desktop on KSS 8.6

  • Hello


    Is there any differences between remote desktop connection procedure on KSS 8.6 and KSS 8.5?


    I'm trying to connect the PC via RDP to Kuka controller with KSS 8.6.7, wich has the default IP 172.31.1.147 through the KLI interface.

    So I can access the shared folder on Kuka from my PC, I can ping it, I can connect it with WorkVisual, but the RDP is not working. Maybe there are some additional settings (except IP setting of course) on Kuka wich has been added in 8.6?


    I also have the robot with KSS 8.5 and it has no problems with RDP connection...

  • AD
  • You could compare KLIConfig.xml between your two installations. The port for RDP must be allowed and is blocked by default. This was also the case in V8.5. But maybe someone already opened the port inside your V8.5 in the past ...


    Fubini

  • Hello, Fubini


    Thank you for answer.

    Well, I tried to compare the files. The 8.5 file is on the left and 8.6 on the right... As you can see, the port 3389 for RDP was allowed by default. The only difference is two ports, but I dont think they has any effect on RDP.



    UPD:

    Discussed the problem with KUKA. As they told, the RDP feature was removed from 8.6 version. So strange desision.

  • From version 8.6 and newer you need the option KUKA.RemoteSupportView for a proper RDP connection. This is what KUKA Germany told me and I can confirm that I was never able to connect via RDP with a KSS 8.6 (or newer) controller without having the above option.


    For versions older than 8.6 it was always possible to connect with adapting the KLIConfig.xml.

  • As I can see, it is not about win10 or win7 but the KUKA's software restriction on KSS 8.6 and above

  • i was working on OPS running KSS8.6 earlier this week (translating some UserTech ).

    I can confirm that RDP works the same way as on KSS8.5 (as far as i could tell...)

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • I think RemoteSupportView is causing something to lock up and require a reboot sometimes when I push updates but I haven't had time to verify that it's the cause. I've been trying to get RDP to work on KSS8.6, but it keeps timing out. I went through the suggested actions - the system is powered on, I can ping its IP address, and remote access is enabled as far as I can tell - but without any luck. I was able to RDP into a KSS8.5 robot when it was here a month ago with no problem. Panic mode is the first person I've seen so far who has been able to RDP into KSS8.6 successfully.

  • I'm commissioning my first KRC4 Compact with KSS8.6 these days. It can be reached using remote desktop when connected to X69, but not over X66. No idea why. Buuuuuuut... I've installed TightVnc, enabled "Connect to RDP sessions" from its settings panel, created an entry for it in kliconfig and we're back to KRC2 times!


    • Helpful

    Finally, got the success in making RDP work on KSS8.6.9. You have to modify 2 files on the robot controller:


    KLIConfig.xml at KRC/Roboter/config/user/common

    KagaConfig.xml at KRC/Roboter/Config/System/Cabinet/


    Find the lines with the entry:

    Code
    <NATRule>rdr [GlobalNatInterface] [addr] port 3389 -&gt; [host:WINDOWS] port 3389 tcp proxy RemoteIP</NATRule>

    and replace it with:

    Code
    <NATRule>rdr [GlobalNatInterface] [addr] port 3389 -&gt; [host:WINDOWS] port 3389 tcp</NATRule>

    Please note that there are two entries in the file KagaConfig.xml.


    Regards

  • Thank you s2007.ravi!!


    Just a small addition for future readers, In order for this configuration to register. A reboot with "Reload files" check box marked, need to be executed

  • I can confirm this works with a C5 micro with KSS 8.7.4

    I can connect by using an RDP client with the following settings

    host: <IP of robot>

    name: KukaUser

    pass: 68kuka1secpw59


    I have an ethernet cable plugged into the XF5 / KLI port

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now