Job Exchanger error

  • Hi everyone,

    I was trying to transfer jobs from my PC to Yaskawa DX200 .. i was able to transfer all the files except 1 file. Which shows following error :


    The code in the job file is:




    ///NPOS 0,0,0,3,0,0

    ///TOOL 0






    ///RCONF 1,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0




    ///DATE 2010/10/22 11:02

    ///ATTR SC,RW

    ///GROUP1 RB1



    MOVJ P000 VJ=20.00


    GETS PX001 $PX001

    GETE D001 P001 (1)

    ADD D001 100000

    SETE P001 (1) D001


    GETS PX002 $PX001

    GETE D002 P002 (2)

    ADD D002 -100000

    SETE P002 (2) D002


    MFRAME UF#(1) PX000 PX001 PX002


    MACRO1 MJ#(0)



    Note: All the files which I am trying to transfer are given by yaskawa as sample files for using a MotoPLUS program with name "CtrlSensor", and we are supposed to call job from this motoplus function.

    Any help would be really appreciated.

    Thanks in Advance

    Gurtej Singh

  • AD
  • Did you load the Macro job first?

    Is the Macro Job set up as an instruction and any/all arguments set up?

    The problem is more than likely with the MACRO.DAT file not matching.

    I know a thing or two, because I’ve seen a thing or two. Don't even ask about a third thing. I won't know it.

  • Problem is resolved i just registered MACRO job on different MACRO instruction and in the JOB code i changed the instruction so it calls right job.

    And later after doing this I tried transferring the job file it worked..!!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now