converting UserTech files to v4.0 (KSS8.6)

  • hello everyone,


    don't have access to KSS8.6 and my OL is only 8.5 so cannot do tests myself. but i am trying to assist someone who is far away and not used to dealing with this kind of things.


    we have used for years sets of files on KSS8.2 and 8.3 but with KUKA moving to Win10 file format changed. Newer UserTech now uses XML version of configuration files... (we have 4.0.15)


    Questions:

    1. Are there any other options (command line switches) for conversion utility "KukaRoboter.UserTech.KfdConverter.exe"? running with -h or --help shows not much.

    2. KFD is apparently converted, with some exceptions (PROSTATEO is now PROSTATE0) which should not be a show stopper. but trying to convert CONFIG file is not going well. according to manual this conversion is supposed to be manual, place file in C:\KRC\USER and then run conversion utility but - nothing happens... and log also shows nothing:

    Quote

    Start converting menu entries ...

    Finished converting old menu entries with 0 error(s).

    for which menu entries, if any, conversion was attempted? if there are no errors, does it mean it was successful? where are the output files? if no menus that need conversions are found, why it does not tell that explicitly?

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • AD
  • What problems do you have exactly?


    Normally the kfd file will be converted automatically to the new version and will be compatible (as they say), but it is not.


    Solution I found so far:

    lets do the automatic conversion to the new version, fix the problems you found, save the original kfd file to a different directory and then delete the original file (otherwise this file will be converted and converted and converted)

  • as described...


    how to do use conversion utility so that there is a clear result if operation was successful or not for a specific CONFIG file, without relying on automatic search through registered paths etc?


    i definitely do not want the user to look through registry (which is a suggestion in manual) to identify paths that conversion utility can use... it is bad enough that program name is frigging mile long.... it took forever to just change keyboard language and test --help and -h options - only to be colossally disappointed with result. <X



    so i would expect option to do something like:

    Code
    KukaRoboter.UserTech.KfdConverter.exe "C:\path1\SmartHMI.exe.OLD.config" "C:\path2\SmartHMI.exe.NEW.config"

    and also something like this

    Code
    KukaRoboter.UserTech.KfdConverter.exe -list_paths

    or rather name such as KFD2KFDX.EXE instead of the current one.


    also there is apparently no "reinitialize UserTech" option any more. what has replaced it? don't want to reboot after every change so - how to test changes right away?


    and there is also no mention of troubleshooting or messages. right now i split my old config into two files to match UserTech V4.x examples. then i did conversion manually.


    and so far first one (Main HMI menu) seem to be ok - we got the keybar loaded, keys seem to work.

    the second part (the ILF menu) also loads but no inline form can be inserted into program.


    in the past i would simply trace this by adding semicolon into KDF inline form so at least command could still be inserted (but of course commented out). not sure how to that in this version...


    apparently simply inserting semicolon into KFDX does not work. i am told that any attempt to insert our ILF results in the same message: TH 3 - Invalid module. (the other message shown in screenshot is not related). It is even unclear which module is invalid. There are no compilation errors anywhere. old KFD worked fine on bunch of installations.


    in the dummy module named test1 standard ILFs work (Motion, WAIT etc.).

    also the module with all subs that my ILFs reference is ok. i can call them from other programs if instruction is typed in manually. but editor fails to insert them, with not much to go on. so presently i am now reading UserTech4.x manual and trying to figure out what else to try....


    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • ok, i found the culprit, also had to replace

    <Argument Name="ParamList">KUKATPUSER;...

    with

    <Argument Name="ParamList">Kuka.UserTech;...

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

  • as mentioned i don't have yet OL8.6 and user is hard to reach and communicate with. restarting smartHMI is not nearly as practical as previously available option to reinitialize UserTech. if that is the only alternative to reboot, it is a huge setback and very poor choice by design team behind UserTech.

    1) read pinned topic: READ FIRST...

    2) if you have an issue with robot, post question in the correct forum section... do NOT contact me directly

    3) read 1 and 2

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now