IRC 5 IP ranges

  • Hey, all. I have a customer who has an IRC5 that was delivered with the Ethernet/IP AnyBus option, but never used it until now. I need to activate the AnyBus interface and connect it to a PLC.

    This looks completely straightforward, but I've noticed a potential issue. This robot was also delivered with the Discrete I/O option, and has a DSQC-1030 on the IP address Now, this module isn't being used for anything, but it's still present and active in the I/O Config.

    What concerns me is that the PLC EIP network I need to connect to is using the 192.168.125.* subnet. So setting the AnyBus adapter to anything compatible, it seems like this creates a potential conflict in the IP range with the LAN port

    I've never run into this before, so I'm wondering:

    1. are there any prohibitions on using 192.168.125.* on the AnyBus port (or the LAN3 or WAN ports) in parallel with this Discrete I/O module?
      1. Actually, are there any prohibited IP ranges for the "public" network ports on the IRC5?
    2. Would I need to delete the Discrete I/O module to avoid conflicts with using that IP on the AnyBus port?
    3. Is there any way to get around this potential conflict using clever NetMask settings? The last time I tried using anything other than, the robot rebooted into System Failure until I reverted the change.
  • I've been reading the Ethernet/IP manual, and the AnyBus manual, but if there's a manual that goes in-depth on all of the ethernet ports and their potential interactions, I'll take it gladly.

    I encountered the netmask issue literally a month ago, on an IRC5 running RobotWare 9.06. And had a couple of co-workers encounter the same issue. On those robots, though, we had the freedom to change the IP addresses to fix the issue.

    My foremost concern is determining whether or not I can set the AnyBus port to an IP on the 192.168.125.* subnet at all, and what steps I need to take to make that happen.

    And if setting the AnyBus port to anything on that subnet is forbidden (NICs with overlapping IP ranges are generally verboten), then I need to figure out what my options are.

  • Update: This job got pushed back a few weeks, but I finally got to it a few days ago. Setting the AnyBus adapter to 192.168.125.* worked fine. There was no conflict between that and the "Local I/O" and Service Port network. Despite the fact that I had two networks using the same IP range, the IRC5 appears to keep them segregated somehow.

  • Hi there,

    I have some problems related, i think, with yours: only two IRC5 - RW 6.08.01 from more than ten identical robots connected to the same network, entered in a system failure state, aparently after a network loop (PROFINET). The robots restarted by themselves and a gap in the event log and the only error '20195: System data from las shutdown is lost' appeared.

    Someone knows why only two of more than ten robots are having this problem? We had the same problem months ago, and not in all robots, after changing network configuration (all device IPs in the network to change management parameters in a switch...).

    The only difference, is that in robots with that problem, we don't have a Local_IO (EtherNet/IP Device) defined, while in robots that didn't have the system failure, we have it (DSQC1030 with IP ).

    We don't know if this parameter could be the reason for the differences. Also, we don't know why the robot restarts by itself when detecting a network loop/changes in switches.

    Someone knows what can we do to avoid this?

    Thanks in advance!

  • Thanks! we hope no more network loops happens but it doesn´t depend on us... So, if there are any changes we can make on the robot's configuration to protect it, we 'd like to to know about it!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now