Weld Speed

  • Good morning!


    I am programing a weld for joining two pipes together using a headstock on a YRC1000 and for some reason the headstock is rotating muck faster than the ASF weld speed that I set. I have already changed the speed to tag on the line to unused for both the robot and the headstock, but it changed nothing. Any help in resolving this would be greatly appreciated. Thanks

  • Place your Ad here!
  • 1) Is the job's group set a Robot+External:External? Example, R1+S1:S1.


    2) Are the moves when the external axis is moving SMOV + MOVJ?


    3) Is the external axis properly calibrated to the robot? Synchronous jogging works correctly?


    4) Are you thinking in the same units that the controller is using? CM/min, in/min, mm/sec, or mm/min.

    I know a thing or two, because I’ve seen a thing or two. Don't even ask about a third thing. I won't know it.

  • MOVL: 750

    +MOVJ: 25.00

    ASF(2) (speed is set in here)

    MOVL

    +MOVJ

    AEF(2)

    MOVL: 750

    +MOVJ: 25.00



    The move in between the ARCON and ARCOF is independent motion, not coordinated motion. The move should be a SMOV + MOVJ.


    I would also expect welding pipes together SMOVC, unless they are fishmouthed or you are doing a simple tack.

    I know a thing or two, because I’ve seen a thing or two. Don't even ask about a third thing. I won't know it.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners