Putting an IRB S4C back into service

  • Hey guys,

    I was tasked with putting an IRB 140 with a S4C Controller back into service at my university. Now theres a load of errors on start and I'm not sure in which order I have to solve them to get this thing working again. The Robot was out of order for around half a year.

    Errors are:

    Error 38071 (battery is not gaining any charge after couple hours of the controller being switched on so I'll prolly have to get a new one right?)

    Error 38001 (this is caused by the dead battery I reckon)

    Error 38031 on axis 4,5 and 6 (if I understood correctly this means something is faulty, either broken or disconnected cables, dead smb or dead smb battery right?)

    Error 50242 on all axis (Unsync due to cfg)

    Error 50057 on axis 5 and 6 (joint not synchronized)

    Error 20032 on all axis (rev counter not updated)

    Error 10014 (fatal error) (this was listed several times on startup)

    What i could try up to this point: To fix 10014 I restarted the controller multiple times (Warm start) but it still kept popping up, though the amount of times it was listed after each restart varied between 1 and 3). I have no clue on how to resolve this due to the ambigous nature of this message. So I ignored it and tried my luck with 50242, 50057 and 20032.

    To fix those I tried jogging the robot in sync pose and update the rev counters. But when I pressed the enable motors button I got one of 2 error messages, either 20054 (not allowed when Programm is executing) or 20076 (fatal system error, therefore not allowed). 20054 happened way more often than the other one and I dont know what the cause of that is. There is no programm running (I cant even load one because of 10014) and I pressed the programm stop button (the black one in the bottom left corner) multiple times but that didnt help either.

    So I'm kinda at a loss at this point. Only thing I can do is to change the battery and check if I find some obvious faults with the cables. But because I cant move or jog the robot checking if theres a loose contact is somewhat difficult.

    Any help would be greatly appreciated.

  • When you check your cable connections: Just because it is firmly attached does not mean that it is ok. While power is off, disconnect the cable connections, look inside to ensure that none are bent (not as likely if it was connected ok) or pins pushed in (more likely if the connection was good).

  • Is this an S4C controller or S4C+ (M2000)?

    The 38031 resolver error is the one to concentrate on. Does it come up when the controller first powers on or when you try to jog the robot?

    Look at the the Serial Measurement Unit (SMU) in the base of robot and make sure all the connectors are properly seated, specially the FB4-6 connector. If the 38031 happens when you jog, then make sure the FB4-6 cable shielding is cable tied to the metal bracket the SMU is mounted to.

    Regarding the battery pack. If it has an orange 2-pin connector and 6-cell 7.2V NiCad pack, it is rechargeable and needs 24 hrs to recharge if it's still good. If the battery pack has 3-cells with orange or black connector, it is a non-rechargeable 10.8V lithium pack and needs to be replaced if it measuring below 8.0V.

  • Thanks for the fast replies.

    It's a S4C plus M2000 controller and the 38031 comes up directly after the controller gets powered on. When I try to jog either 20054 or 20076 pop up immediately with 20054 happening most of the time.

    I will check the cables today and see what type of battery I have.

    Edited 2 times, last by Fiftyjens: Thought it was a S4C because of the housing but the plaque says S4C plus M2000. ().

  • I checked the robot and it uses a 3 cell 10.8 V lithium battery pack and its dead, so I try to get my hands in a new one.

    The cables seem to be properly connected and the shielding of both the 1-3 and 4-6 are cable tied to the metal bracket. I didn't pull out any of the individual cables though because they felt somewhat brittle and fragile and I didn't want to break them just yet.

    The last time the robot was in service (bout 6-8 months ago) it was able to function and since then it wasnt moved or turned on so I doubt that the cables somehow broke during that time.

    • Helpful

    Try the easiest thing first - loosen the FB4-6 connector at the SMU and then reinsert it to make sure it isn't a loose connection.

    You need to pull a couple of covers to look over the 4-6 signal cable going up to the motors, make sure it's not pinched or worn anywhere.

    The prints for the robot are in the manual if you're handy with a meter. The manual for the M2000-2004 IRB140 is >here<.

    A 38031 error is caused by SMU, the resolver, or the cables in-between. Since the error is all 3 upper axes, the common cause is the SMU itself or a short in axis 4, 5, or 6 exciter circuit.

  • Thank you for your answers. I spoke with my supervisor and he told me thats something the electronics department will take care of, since they wanted to replace the cables ages ago. I forwarded your replies and they will test and repair the robot.

    Thanks again

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now