Fanuc and IRvision - Offset when picking up a part which is at an angle

  • AD
  • Fabian Munoz thanks for your time


    The area from which I am picking up is an area of about 15 cm by 10 cm. The search window and snap window are configured to ensure that the parts are recognized within these bounds. I am sorry but I am not sure what you mean by grid? Hopefully you got a little more info of my application


    When I put the parts in the search window, the IR vision finds the parts without any problem. I know this since the IRvision program draws a green box around the part. IR vision also shows the origin of each part with a + sign on each part too. Please see an illustration of the same



    I tried putting one part in the "horizontal" orientation, and another part at 45 degrees to it, and I got the box and origin at the places where I expected.


    The origin is shown with a small green + sign, however the + sign doesn't change its orientation with the angle of the part. I am assuming that is by design, since the robot doesn't make a rotational error while picking up the part, it only makes a transnational error.

  • Your Z height must be set to the distance from UF[3] to the surface of your part. If your part is cylindrical and can roll then that could be part of the problem. It is a 2D vision system being presented with a curved surface. I know there are 3D vision systems that can easily handle that situation, but I haven't attempted it myself with 2D.

  • HawkME


    Thanks for your response!


    I am using grippers to pick up the cylindrical part. I tried changing the Z offset such that the gripper center point coincided with the 1) the surface on which the part sits and 2) the center of the part when its lying down (+3.3 mm). In both cases, it did not help the situation, and I got the exact same behavior from the robot.


    Despite the parts being cylindrical, I have small bumps on the surface which stop the parts from rolling endlessly. in all the IRvision tests for this part, I also ensured that the part was not moving. Actually, another robot that we have set up also uses the IRvision with similar cylindrical parts and it works flawlessly. I am still going to try running my current system with some type of cuboid parts to see if that has some affect.

  • I was told by one of the Fanuc guys directly involve with iRVision the follwing:


    Lets say your grid is 5" by 5 ". You are only getting "perfect" coord if the part is on that particular area. If yo put a part 4" from the center (that's 1/5" outside grid area) the software finds it but interpolates, so there is no "perfect" calculation

    somar

  • Fabian Munoz


    That was a good thought, that's what I assumed too.


    However, The transnational error is the same no matter where I place the part (center, or at the corners of the search window). The transnational error seems to be dependent only on the angle.

    And conversely, when the part is parallel to the robot's y axis, the robot can perfectly pick up the part from anywhere in the search window


    I tested this out a few minutes ago

  • I would look very closely at the other robot that is working flawlessly and see if there are any differences in the iRvision setup.



    Other than that, my advice would be to redo the grid frame set and camera calibration being very meticulous to make sure there are no errors.

  • SOLVED

    HawkME  Fabian Munoz  jmd2777


    The problem was that the camera had shifted slightly after I ran the calibration.


    I ran the calibration again today and now everything works perfect.

    Calibration is a time intensive process since I had to take out some fixtures and stuff to get the robot to position where we wanted it to, but I should've done the calibration much earlier.


    Thanks for everyone who helped

  • Other learnings I had along the way -

    - While setting the first plane for 2-plane-calibration, make sure you reposition the robot after calibration-execution and just before setting the first plane

    -Make sure you choose the correct user-frame in the irvision

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now