Cubic S Area Monitoring Functionality

  • Hey Guys,


    I am having a hell of a time understanding the area monitoring function on Cubic S. I just want a safety output to turn on when the robot is in the zone.


    Would I just have monitoring zone that allows movement, a safety input always off (area monitored), and a safety output that turns on when the robot is in the zone? I want to be sure before I commit electrician time to something that might not work.


    I was able to get the constant area monitoring to work with tool monitoring points.


    Some information:

    E32G Controller

    BX200L Arm

    Cubic S Version 1


    Thanks in advance!

  • AD
  • As Cubic S is a safety device, it is recommended to attend a training course to ensure full understanding of setup, functionality and operational characteristics.


    What I will tell you is, you will learn more by viewing the rung status's of:

    - Monitoring State.

    - Motion Area Monitoring.

    - Any allocated User Safety Output will be allocated to the 'monitoring result' contact.



    A simple test of functionality is below........This is just a demonstration.


    1. Set selected monitored area (x) as prohibited (example below).



    2. Then set motion area common settings (below I am also monitoring for points on arm/segments).



    3. After updating Cubic S Parameters, open up the monitoring state and motion area monitoring.

    - Move the robot so that any of your monitored points can move in and out of the area.

    - You will see the 'result' toggle on and off as you do.



    4. Simply set the User Safety Output (x) for selected area (x) and update Cubic S Parameters.



    5. Now jog the robot in and out of the area and the User Safety Output will toggle the 'result' state.


    The example is set as a 'Selective Prohibited Area', BUT has not been allocated a User Safety Input.

    Therefore, it is not actually preventing motion into the area, only monitoring for it.

    You can see (by way of the 'result' or User Safety Output) if it is in the area or not.


    6. The final test is to allocate a User Safety Input to the Selected Area to control the Selected Function.

    - This would then be a Selected Prohibited Area based on the User Safety Input.

    - When the User Safety Input is ON, the contact in the rung is disabled.

    - The 'monitored result' would then directly break the rung and turn off 'Motivity Shutoff'

    - This would then produce a Cubic S stop event based on the 'monitored result'.

    - Thus turning it into a Selected Prohibited Area by way of a User Safety Input.


    7. If the allocated User Safety Input was OFF, then the contact would be on.

    - Thus turning the Selected Prohibited Area into an unmonitored area.

  • This worked very well thank you.


    I ran into another problem, I keep running into error 1118 on the move after a weld. I read the troubleshooting manual but it isnt very clear to me. I re-wrote the programs to be as smooth as possibe but I havent been able to fix it.

  • Assuming your are referring to E1118 Command Value for JTxx Suddenly Changed.

    This normally relates to what is called a singularity (alignment of the wrist axes).


    A typical indicator when the robot is approaching a singularity is the robot will appear to slow down overall, but one of the axis suddenly starts increasing in velocity (commonly JT4 or JT6).


    The most common way to resolve this is purely application dependent and I cannot say for sure whether it is an acceptable resolution or not but usual resolutions include:

    - Use a JMOVE instead of an LMOVE to the position that causes the error.

    - Use a JMOVE to a Precision Point/Displacement Value/Joint angle posture instead.

    - Teach the position so that a singularity/close to singularity does not occur.


    Further information to the error is below:


  • Here is a sample of the code, I changed all moves around it to JMOVE, slowed them down and even added a point after the weld. I cannot seem to get rid of it. Any help would be appreciated.

  • What is your JT7 external axis Controlling?

    It appears to me to be a servo gun?

    Do you have any other code that is working fine?

    Has this been correctly setup and commissioned as a servo gun regarding parameters and calibration?

    I am questioning the positional values reported for JT7 being negative value in error (command pose).


    Is there any other information you can provide, such as a complete backup (without compromising any company IP) and any information regarding how JT7 was setup and commissioned?

  • Yeah it was a servo gun, I was told that it commands it to go to -70 to reach the squeeze required to weld. The axis is -200 to 230, 230 being open. I am asking for 3kN squeeze, its a huge gun that weighs over 130kg and the TCP is z =1100.



    All the other welds in this program work just fine. The robot welds, then when it is time to open the gun it errors out every time. I have retaught by pressing SHIFT + CL1 to close the gun on the before weld and weld points then just move J7 for the after weld.


    Regarding the parameters it was set up by Kawasaki.



    If you know where to find the parameters you are wondering about in word document I can find them.

  • Well if Kawasaki installed the gun, commissioned and setup the parameters, they would probably have the servo gun datasheets for the parameters and therefore should assume that is all correct.


    Diagnosing your problem remotely like this (especially as it occurs around one weld point) is not easy.


    The deflection compensation (Aux 1027) mentioned in the earlier document is related to different postures of the gun when applying the weld (above, level, below percentages applied in the XYZ directions).


    When force is applied during the weld, depending on the posture of the gun, depends in which direction deflection occurs and is therefore compensated.


    The speed of JT7 before and after weld is controlled by the SPEED value, and the speed of JT7 for the weld is applied via the settings in Aux 1011.


    Initially I would be tempted to:

    - Reduce the SPEED value on the weld step.

    - Change the posture (as much as could get away with) for the weld.

    - Maybe change that to JOINT as opposed to LINEAR.

    - Review Aux 1027 and possibly 'tweak' the percentages relating to your posture.

    - Review Aux 1011 values and possibly 'tweak' these a little.

  • Hey kwakisaki,


    Slowing down the weld point and setting the point before and after to Joint seemed to work.


    You are very big help as I have never received formal training on this type of thing. Just got to figure out the tip wear settings now.


    Cheers

  • Glad I could assist in some way and you've managed to resolve it.........:top:


    The thing is the issue only occurs around one weld, so you run the risk if changing gun settings, introducing problems in areas which are currently working.

    INTERP/SPEED and POSITION are the only real things you can freely change/test for.


    Kawasaki has some complex functions built in for Servo Gun operations, that not everyone uses and when you don't use them, sometimes you can find issues which are not obvious.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now