i can't open any cell in roboguide

  • hello


    i have roboguide V8 and i can create a workcell and save it etc, but when i save my cell and close roboguide and want to open my saved cell i always have the database error you see in the picture after i press ok nothing happens. it just gives the same screen when i open the program.


    -i tried reinstalling i even resetted my pc.

    -i installed the program as an administrator

    -i open the program using administrator.

    -i use FRVC 7.3.

    -i tried opening the cell in another pc and it works without any problem.

  • Place your Ad here!
  • What is the version of the robot that you are trying to recreate?


    I always thought that the FRVC version had to match the robot software version, which would mean that you would only be able to restore a version 7.3 robot. I may be wrong on this, if I am, I would love to know.


    All I know is that I have a universal subscription that covers all versions of RoboGuide. Every time I update RoboGuide, I always update any updated FRVC version as well. I have every FRVC back to 5.3, so I've never seen this error or thought that FRVC versions may be different from the actual controller versions.

  • Roboguide Version 8, but what revision?


    Some of older revisions of V8 didn't work well (or at all) under Windows 10, the OS I suppose You are using, looking at that screenshot.

    i am using revision D the software is supplied by my school so it should be able to work


    What is the version of the robot that you are trying to recreate?


    I always thought that the FRVC version had to match the robot software version, which would mean that you would only be able to restore a version 7.3 robot. I may be wrong on this, if I am, I would love to know.


    All I know is that I have a universal subscription that covers all versions of RoboGuide. Every time I update RoboGuide, I always update any updated FRVC version as well. I have every FRVC back to 5.3, so I've never seen this error or thought that FRVC versions may be different from the actual controller versions.

    the robot software is version 7.3. but i also have the problem when i make a cell save that cell and try to open it again.

    • software version 7.30
    • handling tool H552

    Robot: H854 = M6iB controller (R-30iA)

    these are the specs of the robot provided by my school

    in the screenshot you can see the exact version of roboguide


    the other pc i tried this on is also on windows 10 and one of the newer version of windows 10.


    and thank you both for your quick response

  • Show us a video of:

    a. You opening Roboguide.

    b. Creating a quick Cell.

    c. Saving and closing Roboguide.

    d. Opening Roboguide and opening your cell.

    here is the video:

    External Content youtu.be
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

    note: when opening roboguide in the video it didn't show the run as admin prompt but i do open it as an admin i set the roboguide shortcut to always open as an admin

  • For sure.......exactly as described...........


    I am wondering if FRVC 7.3 was part of the initial installation, or is there a possibility that it came from a later version/revision of Roboguide.


    Have you tried other FRVC versions (an older one/latest one) within your Roboguide and do you get the same results?


    It would make sense to obtain a more recent version of Roboguide, as opposed to maybe trying to resolve this with an older version.

  • What do you mean by "trying to open my program"?


    Are you trying to create a new cell by restoring from backdate.dt?

    If you refer to my original post i meant opening my cell. I changed my original post so it isn't so confusing any more sorry for that, and thank you for helping me

  • the FRVC 7.3 came with the installation folder the school provided. i used the exact same folder on the other pc and on that pc it works. i want to try another version of roboguide but i can't seem to find a download for it. in the screenshot you can find the version of the FRVC and roboguide.

  • the FRVC 7.3 came with the installation folder the school provided. i used the exact same folder on the other pc and on that pc it works.

    This is my point.....they maybe version mismatches.

    If the school are providing a 'self made' copy and not an official one from Fanuc, who knows what mismatched information could be on there.


    I may be wrong, but I don't believe this an actual software issue, except for trial version/version mismatches.


    I am sure you can request for free a latest trial version of Roboguide.

    Here in the UK you can make a request for it via here, just simple email request:

    Intelligent offline 3D robot simulation with ROBOGUIDE (fanuc.eu)

  • Can you try the same thing using V7.20 and also V7.70 and see if the same occurs?

    TPRobot , I would also suggest the same as kwakisaki


    Try with other FRVRC. If it works, You can try to reserialize this working robot to FRVRC 7.30 later.

    i tried v7.20 and v7.70 and have the same issue

    while making the video i also got this error message (see attachment) this only happened while making the video the first time but once i plugged my laptop in my monitor and ran it again i didn't have the error anymore

    it is possible but i used the exact same installation folder on another pc and it works fine on that pc

  • With your selected version in your video, a default robot is loaded R-2000iB/165F.

    If you leave that model selected what happens?


    What happens if you do a complete shutdown of the PC and reboot (not restart), and then open it up again?


    Troubleshooting around older versions (I appreciate you mention other PC's, but all PC's are not the same), when newer versions are available is not really advisable and I suspect if you speak to Fanuc regarding this problem, the first they would do is recommend the latest version.


    Try the above out and see if it repeats itself.


    If someone else here can replicate this issue with your version, it maybe easier to troubleshoot, but the chances of that I think are very slim.

  • I don't remember if these older versions have the Backup Cell option, where the cell is saves as a single .rgx file, that can be after (re)imported.



    I think this was introduced only on later V8 revisions. Anyway, If You version have this feature, You can try to make an .rgx and reopen it.

  • i tried the shut down and turn on but it didn't work, i also tried the different robot and have the same issue. i have already contacted fanuc for a more recent version

    I don't remember if these older versions have the Backup Cell option, where the cell is saves as a single .rgx file, that can be after (re)imported.



    I think this was introduced only on later V8 revisions. Anyway, If You version have this feature, You can try to make an .rgx and reopen it.

    it doesn't have this option but i contacted fanuc for a newer version that should be able to work on my device and with the FRVC i need

  • Well it does seem local to your PC then, short of starting to dig into registry, graphics settings etc, I think you'd get to a point receiving messages of:...try this, try this and try this and becoming frustrated.

    Get hold of a newer revision and go from there.


    Just out of curiosity, have you installed/used this previously on the PC or is it a virtual machine, I noticed it is a trial version?

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners