Motn-171 Overload

  • Hi guys,

    We have a LR Mate 200 id to load our CNC with parts.

    With our bigger and heavier parts we have some troubles.

    First of all, how the robot is set now:

    The max Payload for the robot is obviously 7kg. The Gripper itself is about 1.7kg and the gripped part itself is about 1.4kg, so both together about 3.1kg. Normal picking and placing of the robot isn't an issue at all. The fault appears at the reorientation with 100% Joint speed. The reorientation is from Homepos (-90, 0, 0, 0, -90, -90) to the Waitingpos in front of the loading window of the CNC (90, -75, 70, 0, -90, -90). I know the Waitingpos isn't the best Position for the robot, but we have very limited space to move in.

    The Payload is set properly. I used the fanucs payload esitmation programm with known (weighted) mass. The part is about 150mm away from the flange.

    The Fault:
    The fault appears from to Waitingpos to the loadingpos in the CNC (99, 0, -26, 0, -63, -89.4).

    The programm runs at 80% speed and the fault appears. With 100% run speed this fault appears: DIAG-005 Reducer load excess (G:1 A:2 L:91 P:Programmname.TP)

    I can work with that settings, but I think the robot's lifetime is short, when we let it run 24/7 with this faults.

    What can i do? My boss said, last option is reducing run speed.

    Would it help to reduce the distance between the flange and the part (mass center)?

    Thank you in advance

    (and sorry for my bad english :winking_face_with_tongue:)

    Kind Regards

  • Place your Ad here!
  • Reducing that distance could help, but you then would also need to adjust the payload settings.

    The payload estimating program doesn't work if the load is small or close to center. I prefer to calculate with CAD, which should give you a more accurate result if done correctly.

    Acceleration will affect it more than speed. You could do the following:

    J P[2] 100% Fine ACC 75

    Default acc is 100 and you can adjust down to 50.

    • Helpful

    Hi pasu979,

    Per the Alarm Code manual for your second fault:

    Fault: DIAG-005 Reducer load excess (G:%d A:%d L:%d P:%s)

    Cause: Motion is too aggressive

    Remedy: [...] identify the program and line and reduce speed/ACC or position

    Basically, you need to optimize your robot paths, because they are not ideal as it stands. Make sure they are smooth and less abrupt.

    Additionally, did you do the payload with + without the gripped part? Are you using the PAYLOAD[x] command after you pick and drop a part? You'll need to use anything you can to help the robot adapt to the gimnastics you're putting it through.

    Hope that helps.

  • Hi veronicav,

    I did a Payload for the empty Gripper and one as well for the Gripper + Part.

    Yes, after closing or opening the Gripper i set the Payload.

    The movement is okay now :grinning_squinting_face:

    Thank you agian.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners