Remove T2 Capabilities

  • Hello,


    We have recently purchased a set of Fanuc robots from an Auction in the United States to use in our Canadian Facility.


    These robots are equipped with Teach 2 capabilities, which are illegal here in Canada, so I am looking to disable them.


    My first idea was to remove the wiring to the key switch so that even if they turned the key to T2, it wouldn't activate it, but I am now concerned about leaving the robot in a state of not knowing what operating mode it is in.


    As I am typing this, I'm thinking instead of removing the wiring, to re-route it to turn on T1, so if the key is in the T1 or T2 position, T1 is active.


    Any comments, suggestions, concerns or better ideas for me?


    Thanks,

  • Place your Ad here!
    • Helpful

    I did this on some RJ3iB robots, and I wired a jumper for the T2 contact so that when the operator placed the robot into T2 mode, it would stay in T1.


    For your case though, the robot defaults to T1 even if you disconnect the teach switch entirely. You would be fine if you removed the wiring.


    In my case, it was an issue, because on that era of controller, if you removed the wiring the robot would default to T2. Fanuc fixed this on the R30iA version of controller.

    Check out the Fanuc position converter I wrote here! Now open source!

    Check out my example Fanuc Ethernet/IP Explicit Messaging program here!

  • I think for R-30iA, you need to remove the wire going to the Tyco connector pin B2 (the other end from the auto/T1 switch)

    Follow it back to the T1/T2 switch contacts and pull it off there. Then try it and let us know, please.


    If I'm right, the robot will show T1 mode when you put the switch in T2, disabling T2

  • You have two choicesas it should be properly done:

    1. Buy two position switch from Fanuc - there are T1 and AUTO only, replace yours and this solves the problem.

    2. Set the system variable $SCR.$T2_LOCK_ENB = 1 (originally it's = 0) - and this also solves the problem - robot, when switched to T2, shows the message T2 disabled and that's all :smiling_face: No changing in wires needed :smiling_face:

    This system variable needs to be set in Controlled start.

  • You have two choicesas it should be properly done:

    1. Buy two position switch from Fanuc - there are T1 and AUTO only, replace yours and this solves the problem.

    2. Set the system variable $SCR.$T2_LOCK_ENB = 1 (originally it's = 0) - and this also solves the problem - robot, when switched to T2, shows the message T2 disabled and that's all :smiling_face: No changing in wires needed :smiling_face:

    This system variable needs to be set in Controlled start.

    I have used option 2 in the past and it works just fine. I left the three position switch alone.

  • You have two choicesas it should be properly done:

    1. Buy two position switch from Fanuc - there are T1 and AUTO only, replace yours and this solves the problem.

    2. Set the system variable $SCR.$T2_LOCK_ENB = 1 (originally it's = 0) - and this also solves the problem - robot, when switched to T2, shows the message T2 disabled and that's all :smiling_face: No changing in wires needed :smiling_face:

    This system variable needs to be set in Controlled start.

    Hello,


    I get that message when trying to modify that variable

    Variable/ field write-protected

    Is there an other option to modify it?


    Thank you



    Edit:

    Found a solution:

    I created a program and run it

    Code
    $SCR.$T2_LOCK_ENB = 1

    and T2 is Disabled now


    Thanks again

    Edited once, last by MoEL ().

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners