Fanuc R-J2 (S-420iF) hangs up shortly after successful start

  • Hello,

    We have recently purchased an old Fanuc S-420iF robot with an R-J2 controller and we have at least a problem with it. We know that we could contact Fanuc or a specialized company but their intervention would cost time than the double or triple of what we have paid for the robot and, as a family company struggling to start, we do not have the money at this stage. It is a also good opportunity for us to learn more about our robot.

    The system boots up correctly (with some faults, notably the SRVO 062, because the batteries were depleted) and we can navigate the menus. However, in 1-2 minutes after power on the whole system hangs up: the teach pendant does not respond anymore (without a specific message of any sort) and a red LED (the one of the right) lights up on the main CPU board.

    The teach pendant/controller hangs up regardless whether we navigate the menus or just let it wait.

    It is very important to note that it does not hang when started in bmon (boot monitor).

    We have done a COLD START but this hasn't fixed the problem.

    The image below shows the status of the main CPU board LEDs in the hung up state.

    The green LED-s are on since the end of the initial tests. According to a version of the "FANUC Robotics SYSTEM R-J2 Controller Maintenance Manual" that we found on the internet, they indicate that “If the robot’s status is normal, all the status LEDs will be lit.” According to the same manual, the status and alarm LEDs indicate that the main CPU board passes (before the teach pendant is ready to display) successfully a number of tests regarding the CPU PC board, the memory modules and the axis module. Which tells us that these modules should be ok. Unfortunately this manual does not say what happens to the alarm LEDs after the teach pendant is ready to display. We guess that it is the software (Sealing Tool for this controller) manual that presents that.

    We do not have any Sealing Tool manual so we would grateful for any help in fixing this problem.

    For your reference:

    Sealing Tool 7D60

    Software Edition No. V4.30P/88

    Teach Pendant 7D01/09I

    Boot Monitor version 4.22P (01E)

    We would be equally grateful for a manual of Sealing Tool/R-J2.

    Thank you for your attention,


  • AD
  • I do not think it is a software problem.

    It is a servo alarm on the cpu-board.

    The red leds are independant from the green ones, so when a fault comes after start up, the green leds are on as well.

    First disconnect all connectors of the cpu-board and reseat them. sometimes this is enough.

    Do the same with the axis modules on the servodrive, but I don't think this will help, because there is no fault message.

    Try to make a back-up from the controller and an -all of above- back-up.

    replace the cpu-board.

  • Dear Erik and kluk-kluk,

    Thank you very much for your replies !

    Below I will try to answer the questions of Erik and then and ask for further advice regarding the backup of the system.

    While in bmon the controller/pendant does not hang up.

    We have tested again today and this time waited for 20 minutes. The teach pendant remained responsive.

    We have done yet another cold start, no change.

    Updated info: the time before hanging up can be longer sometimes, up to four minutes recently.

    Unfortunately we do not have any copy of the software that came with the system.

    Sealing Tool is not something that is important for us but we do not have anything else.

    Handling Tool or any other tool that is compatible with S-420iF would be fine for us if we could get a copy...

    Meanwhile a backup of the system is on top of our list of things to do and the next question we wanted to ask was whether we can attempt a backup in these conditions. The fact that it does not hang up in bmon is reassuring but I do not know how much we risk if we go ahead with the backup before we have fixed the problem.

    If I understand well kluk-kluk then we should go ahead with the backup. Is that right?

    We will reseat the connectors to the CPU board and we will inform you on the result.

    While here I have a question regarding the backup. I know that it can be done using kfloppy and a serial cable but we are tempted to buy a PCMCIA interface for R-J2 and an SRAM card. There is no interface in the controller but I found about this while reading this forum. This would make the backup a much faster operation (and less risky maybe).

    Do you know whether the PCMCIA interface is readily recognized by the controller?

    Or do we need additional software from Fanuc for it to be recognized?

    Thank you again for your help and attention,


  • A few more updates on this old thread:

    We tried to back up the system using kfloppy but the transfer hung up.

    Hoping that a faster backup using SRAM card will be more successful we purchased the necessary hardware (memory card reader and two SRAM cards) and then tried again. The backup hangs up again, all three red ALARM lights turn on.

    We have also purchased a replacement CPU board but it doesn't have any software. We hoped that we will be able to load the content of the present CPU but this appears to be a dead end at this point (we do not have floppies).

    Any ideas or suggestions?

    The obvious thing to do would be to load a fresh system.

    Does any of you have a S-420 iF compatible tool that we can try to install?

    It does not need to be Sealing Tool, Handling Tool would be just fine.

    We contacted the local Fanuc representatives but they seem to be overloaded, they have been very slow to reply to recent contacts.

  • Make sure NOT to reseat the memory card, it will wipe it!

    The memory card is a small daughter board on the main board.

    We haven't touched any of the modules on the CPU board. The battery was connected at all times when we reseated the CPU board itself.

    From what I read in the R-J2 controller maintenance manual the CPU board has the following daughter boards:

    Flash ROM module

    CMOS RAM module

    DRAM module

    3 axis modules

    From what I understand the CMOS RAM module is the one that's powered by the battery.

    Are you suggesting that we should reseat the other modules?


  • It looks like there is a CPU card communication problem. I don't think there is a problem with the software inside the card itself.


    One of the things we want to check as soon as we have some time is whether the 5 VDC is clean.

    We will place an oscilloscope (in single shot, triggered mode) on the 5VDC power line going to the CPU and look for drops... I will inform you on the results.

  • Here is the RJ-2 red light district :

    Thank you for taking the time to check the LED meanings!

    We have also looked at this but we have a bog doubt whether they apply. On our CPU, the four green lights are on and stay on even when the reds one(s) turn. The manual is clear enough on this subject, my understanding is that the hints given in the manual apply to situations where the green leds are off.

    We will replace the CPU as soon as we manage to load the system on the spare CPU that we just bought.

  • We have also looked at this but we have a bog doubt whether they apply.

    They do apply, the reds and the greens are two independent systems, so a red fault will not affect the green leds.

    In the beginning this confused me as well, but nowadays I have unfortunately a lot of experience with misbehaving RJ-2 robots...

    But it does not matter, watever the leds, replacing the cpu-board (with all the daugterboards) will most probably solve the problem.

    By the way, I will send you a link to the files this afternoon.

  • They do apply, the reds and the greens are two independent systems, so a red fault will not affect the green leds.

    This is very useful to know, the manual is not clear on this subject. Thank you very much!

  • When you get the replacement Main Board, try swapping only the 3 servo cards. This won't effect memory and there is a chance a bad servo card is causing the fault. Only takes a few minutes and worth salvaging the software.

    You mentioned that Kfloppy is hanging up - where/when does this happen?

    How did the 5V monitoring turn out. I would keep the scope in continuous and just look for any ripple or drop in voltage during bootup. If the 5V was the issue, I would expect more randomness in the fault as weak supplies tend to be susceptible to temperature changes.

    If you do need software, I recommend HandlingTool V4.40P if you can find it. It was always stable with the latest the R-J2 had to offer.

  • Hello colleague.

    I have an s420 iF for educational purposes. And the same problem has arisen, I cannot enter the Boot Monitor.

    Check the TP cable, it is OK. The strange thing is that sometimes, it allows me to enter BootMonitor but after 10 seconds, the TP is stuck and does not respond.

    In the manuals I have, I can't find a troubleshooting guide directly associated with this problem.

    In my case, the LIGHTS that the CPU turns on are 4 green and 3 red. Sometimes it changes to the 2 red ones on the left side.

    It is a fault that I cannot identify because it usually changes states, it drives me crazy. ha ha ha ha ha ha

    It is very similar to the fault that they have here.

    Could they fix it?

  • It indeed sounds very similar, and the solution will be very similar too.

    It is bad memory or a bad cpu-board. You will have to replace and reprogram it.

    If the robot has been stored in moist condition the contakts of the memory can be oxydised and cleaning can be helpfull.

    Remember that removing the memory whipes it !

    Since bootmonitor is having problems… you are sure the PSU is ok ?

  • Thanks friends.

    I managed to find the fault, if it was the power supply, the strange thing is that it does not mark any fault. It seems that the 5V continuous power component to the CPU becomes alternating or noisy.

    I have a fanunc S-420iW power supply code A16B-1212-0871/13C and it works with that.

    The original source is A16B-1212-0871/12C

    My question now is, will it not have long-term failures? Are the fonts compatible?

    In the RJ-2 maintenance manual that I have, only the codes up to A16B-1212-0871 appear.

    If you can leave me with that peace of mind that I am placing this other power supply unit correctly, the /13C?

    Thanks for your time

  • A16B-1212-0871 is the part number

    /13C is the revision level, the higher the number, the newer the revision.

    Although Fanuc has a few exceptions, most Fanuc parts are interchangeable if the part number is the same and the revision level is not.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now