Issue with DeviceNET Inputs KRC2ed05

  • Hello all,


    I am in the process of adding some simple I/O to my robot, specifically a Terminator T1K-DEVNETS with one 8-point input and one 8-point output module. My robot controller is a Krc2 Ed05 running 5.3.2.


    I am running into an issue where I have everything seemingly installed correctly, power attached, resistors installed, the inputs lights on the module light up when activated, but I can not get the inputs to show up on the input monitor or mid program. I have tried different addresses to see if that helps in case I was overlapping something else in the system but still a no-go.


    Here are the DEVNET.INI, IOSYS.INI, DEVNET.LOG, and IOSYS.LOG. I am not seeing any errors or anything out of place but If you guys could give it a once over I would appreciate it.


    Also attached are what shows up when I run the Telnet "dnShow1" and "dnWho".


    I have worked through the entire DevNET manual to install and map the I/O, is there anything I may have missed to get my I/O to work properly? Any advice would be greatly appreciated.

    Code: DEVNET.INI
    [krc]
    debug=1
    baudrate=500
    logfile=1
    [1]
    macid=10

  • AD
  • massula

    Approved the thread.
  • Well, your detailed telnet appears to show that the device has 3 bytes in and out. It's possible that the unit on MAC Address 10 has some diagnostic/control bits on the first byte. I would try expanding your x1 to x3 in IOSYS.INI, do an IO-Reconfig or cold reboot, and see what happens. If this does not generate any Devnet errors, then your I/O might be mapped somewhere between 9 and 24.

  • Worked like a charm! I did both things, changed to x3 and changed to INB/OUTB and the inputs are registering finally. I saw in the Terminator manual something about Diagnostic information but I did not know how to correlate that with my issue. Thank you both for your help.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now