Comarc Issues not working?

  • Hello people.


    I have some issues trying to make work the COMARC instruction. I read through the documentation and strictly followed it.


    I put U/D at 174 (the current we're using with our welding program) and L/R at 0 at first.


    First finding the compensation value while putting S1E197 at 1 and comarc mode to valid. (Found something around 50ms)


    After that, I tried finding L/R doing a second welding and I found 4.2 as a result.


    In the end, the SCOMARC doesn't do anything, it doesn't help staying in the seam.

    For information the cell has been verified and calibrated by Yaskawa.

    The robot I'm using is a MA1900 and the controller is the DX100. We're using an external axis that's why we're using the SCOMARC (I can't even find the COMARC instruction anywhere).
    Our welding machine is a EWM Phoenix 552.


    I also called Yaskawa and they are the one who told me to put the L/R at first, i'm trying to call them again to have more help. I figured I would ask you too in case I missed something!

  • Place your Ad here!
  • SCOMARC is used when you are using coordinated motion (R1+S1:S1). Don't use it if you aren't doing a coordinated motion job


    The rule of thumb with COMARC is:

    - set up good set of weld parameters and weld job with the electrode at the leading edge of the puddle

    - set up your weave amplitude and frequency using a Single weave (frequency is paramount)

    - when ready, turn on COMARC MEASUREMENT MODE

    - set S1E 197=1 to find out the appropriate parameter and time lag, and set the parameter

    - set S1E 197=0 to find out the appropriate U/D and L/R and put those values in your job

    - turn COMARC MEASUREMENT MODE to OFF

    - test a weld


    If it doesn't work, test it out from scratch again. If you screw something up in COMARC, sometimes it's just better to start over....

  • Hi, thanks for you answer.

    The thing is, SCOMARC is the only command available, I can't find the COMARC option anywhere.

    About what you said, do I need different parameters for the comarc for each weave i'm using? Or are the COMARC parameters universal for every weave?


    Also, I called Yaskawa and this is what they told me:

    U/D is supposed to be equal to the intensity of the job I'm using (here 174)

    L/R need to be set at 0 first. Then I need to determine my compensation phase value aka time lag.

    Then I can do a job to determine my L/R which is supposed to be not far from 0 (like 10 and more is too much apparently?)

  • So what you are saying is that when in a R1 only job the COMARCON instruction is not available?


    When you are collecting data do it on the positioner. This allows the system to measure data using the full grounding system.


    As Roboprof stated. Put system in measure mode. Setup the weld with a weave. There should be no defects in the sample ie. undercut, roll over lack of fusion ext.

    Make sure the weave is weaving in the correct direction (not stitching) Recommended single mode, HZ 3.0, Amp 2.5 for setting up. replace weave instruction with COMARCON. Set 197 =1. Run the weld with one plate missing. Set PC data in the appreciate SE parameter (Use the collected data).

    Set 197=0 and run the same weld again. Register the Comarc condition. Change the L/R data to 0. Take the system out of measure mode and test. You can then adjust the L/R data by .5 amps at a time if the weld is not in the seam. If it completely tracks out start over.

  • Hi.

    I didn't try to make a job with only R1 so that might be the problem, i'm gonna try that.


    Yeah I was using the positioner already but thanks for the reminder.

    Alright I'm gonna try that as soon as I can, thanks people.

  • what RoboProf and RobotRuler are saying:


    If the job has a control group of only a robot (R1) use the COMARCON instruction.


    If the job has a control group of a robot and an external axis (R1+S1:S1) use the SCOMARC instruction.


    Using the wrong instruction with the wrong hardware won't work.

    I know a thing or two, because I’ve seen a thing or two. Don't even ask about a third thing. I won't know it.

  • Thanks to you guys and after reading the manual numerous times, I found what was wrong.

    The width setting was too low. I tried with a 4mm width and it worked!

  • Hi there.


    I've got a question. In manual I can find that I can do only one measurement per JOB. Fine. But what's with using COMARCON? I mean: I have to weld 5 pieces in one JOB, can I just copy welding section 5 times, just changing teaching points? Can I use COMARCON/OFF more than once in same JOB?

  • Hi there.


    I've got a question. In manual I can find that I can do only one measurement per JOB. Fine. But what's with using COMARCON? I mean: I have to weld 5 pieces in one JOB, can I just copy welding section 5 times, just changing teaching points? Can I use COMARCON/OFF more than once in same JOB?

    You can use ComArc function as many times in a welding job as you want. Doesn't matter if the setting values U/D and L/R are same or not.

  • Very late to this thread just have a few queries,


    I am currently trying to set up a test comarc weld.


    The weld is straightforward on one axis.


    The plate thicknesses are both 10mm forming a 90-degree angle between the Horizontal and Wall as per the manual.


    In parameters, the nearest option is S1Exxx, so I changed the 197 to 1 and the prompt that the measure mode was initialised showed in the message box.


    I used the weave variables as below. Just to clarify the not stitching comment I have the weave moving near vertical with a weld angle of 45 degrees going from plate a to plate b is this correct?

    Make sure the weave is weaving in the correct direction (not stitching) Recommended single mode, HZ 3.0, Amp 2.5 for setting up. replace weave instruction with COMARCON. Set 197 =1. Run the weld with one plate missing. Set PC data in the appreciate SE parameter (Use the collected data).

    I got a Para No. of 110 to be set to 321 (Is this very high, or does it vary between welding units)


    Set 197=0 and run the same weld again. Register the Comarc condition. Change the L/R data to 0. Take the system out of measure mode and test. You can then adjust the L/R data by .5 amps at a time if the weld is not in the seam. If it completely tracks out start over.


    The Current was 55 with an O.Current of 6.2 (Do these values seem reasonable?) or should I ignore the O.current and set it to zero as robotruler stated and work up?


    Any help would be greatly appreciated.


    P.S. Every weld I have conducted thereafter is not tracking the seem so these values are wrong looking for any ideas of what I might be doing wrong

  • I have reread all the comments I have been completing the procedure correctly is there any special setting I must change the welder to??


    I am running a Fronius 500i tps welding unit

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners