Roboguide freezes while opening workcell

  • Hi, I have serious problem with roboguide v9 rev Q. I want to say i reinstalled whole roboguide (controllers too), tryed all ways of opening workcell (from roboguide, from file, from backup). My problem is, when i try to open workcell, my virtual controller wont write anything and after small clock with robot (indicator that something is happening) disappear, nothing happens, only blank controller as is shown in the picture. I am afraid there is something wrong in the registry so i have to reinstall whole PC, but i cant do that now, so if you have any ideas, try to help me. Thank you




  • Place your Ad here!
  • Certain Antivirus might be interfering. Once my antivirus prevented me from saving any workcells and break my workcells so bad I couldn't open them anymore afterwards.


    Also when opening a cell with multiple robots I had problems with occupied ports.

  • Hi, thanks for answer, but nothing worked. I contacted FANUC and they suggested the same, and still have no answer... So I am waiting for their next response.

  • Completely understand regarding using system restore, I was in a similar position too, but I just imaged my HD before just in case.


    Instead of waiting, may be worthwhile obtaining HD image app, cloning the HD and then trying various methods out.......Just a thought.


    I use Arconis True Image for HD Imaging, works very well indeed.

  • If anyone is interrested in this issue, Roboguide support central said that they are unable to reproduce my error, so it must be something on my PC and if I want to use roboguide, I have to reinstall Windows...

  • Problem -kind of- solved

    If you cant open project (you get same problems as i do), follow these steps:
    1. Open some other project that doesnt work (in my case, any other project)

    2. Wait until controler loads and is blank (nothing is happening)

    3. DO NOT TURN Roboguide off and dont shut down RG processes

    4. Open any other project that isn'n working

    5. Now there should be some progres in teach pendatn (text flashing, loading stuff)

    6. In my case, TP was stuck on control start and waited for FCNT -> ENTER, but the waiting window was still up (over TP and over FCNT button !!!!), so you have to right click on TP and turn on TP key pad

    7. Press FCNT -> ColdStart -> ENTER

    8. Done, now you can work on your cell, but still cant create new ones :frowning_face:


    I'v also got some new info from Fanuc. They say that its GPU problem, but i really doubt it.

  • I had the exact same problem with Roboguide 9 Ver R.

    Worked perfectly and one day it just stopped working .


    Here's what worked for me :

    1. Open Registry editor

    2. Delete key HKEY_CURRENT_USER\SOFTWARE\FANUC

    3. Delete key HKEY_CURRENT_USER\SOFTWARE\VB and VBA Program Settings\RGCore

    4. Delete key HKEY_CURRENT_USER\SOFTWARE\VB and VBA Program Settings\SimPRO

    5. Start Roboguide and it re-generates those keys defaults


    Worked like a charm for me

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now

Advertising from our partners