Fanuc Webserver through VPN

  • Hi,

    We have an installation with a Fanuc robot. We would like to use a VPN to connect with the webserver. I'm able to connect with my pc with the robot through a Siemens switch. But if I try this with a remote connect vpn-module (Siemens Scalance M) the ECHO function of the robot fails to connect.

    So i'm sure that I can connect with my pc to that robot, but I'm not able to do it wireless.

    Can anyone help me?

  • AD
  • Hi,

    I can ping the robot and can connect to the webserver. When I try to open the ECHO it says (Pmon-001 Failed to notify PC Monitor,HRTL-061 Ethernet Connection refused). I can see those errors in the error screen of the webserver. The robotcontroller is a v7.70p/53 R-2000iB/210F.

  • 1. Are you using Internet Explorer?

    2. Have you allowed Internet Explorer through the Windows Firewall?

    3. Have you added the IP address of the robot to Trusted Sites in IE?

    4. Are you able to use ECHO when local with the robot?

  • 1. Yes

    2. Yes

    3. Not possible because my network is controlled by IT

    4. Yes

    Through the VPN I'm able to see the webserver, but once I open the ECHO it fails.

    The VPN uses NAT to modify the IP. Can this have something to do with it?

    Edited 2 times, last by RoboRuben: Aditional info ().

  • Under the trusted sites setup, do you have active x enabled? Also, are all pop-ups un-blocked? Your trusted sites configuration should basically be as open as possible. When choosing the settings, just ask yourself "what would the IT department do?" and do the opposite.

    If possible, try to completely disable any firewall you may be running. If that works, start re-enabling each program until you figure out the culprit. You will probably need IT assistance to allow you to do this, but I have found that IT folks are happy to help when they can feel useful.

  • Hey,

    It worked once we put software R843 "remote iPendant" in the robot.

    By buying this software we are now able to connect through port 80 with the webserver. This even while using google chrome.

  • I've had a similar issue with connecting to a robot through a remote VPN connection.

    It sounds like you've already established a connection to the robot through a Siemens switch but are experiencing issues when connecting wirelessly through a remote VPN module.

    You could try switching to a different VPN provider or configuring your current VPN differently. However, another alternative to consider is using a proxy service, which can provide a stable connection and be tailored to your specific needs.

    You can also try private proxies for price tracking as an option.

    Edited once, last by reiddan ().

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now