Non-safe Siemens PLC controlling KRC4

  • Hello,


    I want to implement the control of the KRC4 controller with a Siemens PLC as detailed in the Kuka SI manuals to monitor system variables and control program execution with the PLC, but I am still handling the safety of the robot through the physical X11 interface instead of through Profisafe.


    My problem is that I don't currently have a F-CPU to try it, only a regular S7-1200, and when importing the KRC4 GSDML to TIA Portal it says "An F-Module in safety mode can only be used by an F-CPU in which F-capability is enabled". Is there a way to work with higher level control without a safety PLC?


    I haven't found a way to disable the safety features in the KRC4 "module" on TIA Portal and I even tried to edit the GSDML but it's much harder than I thought.


    Has anyone dealt with the same problem and can help me?


    Thanks

  • AD
  • Thanks, for the fast response panic mode , I already managed to solve it by deleting the whole safe IO in the KRC4 module in TIA Portal. My problem was that the GSDML already included these safe IO although I had already disabled them in the Profinet configuration in WoV, so the issue was on the Siemens side.


    I attach a photo of what I deleted in case it's of any use to somebody.


    With that solved I'm now trying to solve a seemingly unrelated error where the communication between the PLC and robot controller seems to fail intermittently. In the PLC's diagnostic buffer I get the error: "Error on partner - Wrong partner". This error appears intermittently but the PLC doesn't stop and I'm controlling the robot without issues.

    Any clue as to why this is happening?

  • I've found the answer to this issue on the Siemens Industry Support Forum, here is the link:


    In summary, if anyone wants to use an S7-1200 with the KRC4 the small detail to take into account is that in the TIA Portal Topology View the PLC and robot controller should not be connected through the Profinet interface. It's not really clear why but it worked for me.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account
Sign up for a new account in our community. It's easy!
Register a new account
Sign in
Already have an account? Sign in here.
Sign in Now